Portal 2
Portal 2 > General Discussions > Topic Details
Feyawen Jun 17, 2014 @ 9:17pm
June 18, 2014 Update Broke Portal 2 Authoring Tools / Hammer
Since the update earlier today, Hammer is constantly locking up. I'm not getting a specific error, just "not responding..." And yes I know some things take time and "not responding" doesn't mean it's not responding always. But it's not my first day in Hammer, I know when it's really locked up. It will literally go to "not responding" simply if I switch off the window and back to it (like if I switch into Portal 2 to test my map, or switch to Firefox to look something up on the web.)

Another sure fire way to lock up for me is the Model Browser. For example, I was putting together a Laser Emitter and wanted to switch to the Centered model. When I bring up the Model Browser, it just displays a blank white window. Normally the model browser on my PC takes about 5 seconds on first load. I have waited over 2 minutes and still nothing. Then, when I go to close the Model Browser window, all the views in the main window switch to the model browser background and Hammer locks up with a "not responding" error.

This has essentially made Hammer completely useless. I have tried restarting Steam and even restarting my Computer. Still it locks up.

Anybody else having this? And, how the heck do I fix it? It was working flawlessly before the update today (June, 18, 2014).
< >
Showing 1-2 of 2 comments
TeamSpen210 Jun 18, 2014 @ 1:37am 
Try either vertifying your game cache (portal 2 + authoring tools), or if that doesn't work try the download here: http://forums.thinkingwithportals.com/mapping-help/problems-after-17-06-14-update-t9917.html
Commander Makara Jun 28, 2014 @ 6:16am 
Will the authoring tools ever be out of Beta?
< >
Showing 1-2 of 2 comments
Per page: 15 30 50

Portal 2 > General Discussions > Topic Details
Date Posted: Jun 17, 2014 @ 9:17pm
Posts: 2