Portal 2 > General Discussions > Topic Details
PodjeGamen May 29 @ 1:25pm
Co-Op Crash
I was trying to start a game of Co-Op with a good friend of mine. I started the game and invited him, he joined and then we got the usual loading screen. Then I got the screen that says; waiting for your partner. While my friend was still loading, the game suddenly went back to the Main Menu saying my partner has disconnected. But my friend was still on his loading screen.

We tried this several times, but came up in the same situation. Then we turned it around. He started the game and invited me. The roles were now reversed. He got the screen; waiting for your partner and I kept staring at my loading screen which would not progress past the first circle in the lower right corner. Then after roughly 2 minutes my friend said I was 'disconnected' from the game.

Windows Explorer says that the Portal 2 client is still going, so it didn't crash. We also tried multiple times rebooting both our systems and rebooting the Steam client.

Does anybody else has this issue or knows how to fix it?

Thanks!

Showing 1-4 of 4 comments
< >
HackerPide May 30 @ 9:10am 
Check both your friends and your computer if Portal 2 is allowed in the Firewall settings and try turning antivirus off.
Duvel Jun 6 @ 2:20pm 
I've had the same problem as this, playing co-op with a friend who I've played with on numerous occasions. We've left it for a fortnight and tried again tonight and it's still the same. We get the audio link but the game never gets past the "waiting for your partner" screen.
Last edited by Duvel; Jun 6 @ 2:21pm
PodjeGamen Jun 6 @ 2:34pm 
Originally posted by HackerPide:
Check both your friends and your computer if Portal 2 is allowed in the Firewall settings and try turning antivirus off.

We already checked our Firewall settings. And no way am I turning off my antivirus while an internet connection is active. The game should just work fine in my opinions, since other games have no problems with my antivirus software.
Molsten Jun 6 @ 11:18pm 
One possible solution is to browse the workshop (independently) and both subscribe to the same maps. Once they've downloaded (check steam downloads) try connecting again.
Another thing, have you both verified your game cache? (In Library View Portal2>*Rightclick*Properties>Local Files>Verify Integrity of Game Cache)
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: May 29 @ 1:25pm
Posts: 4