Ravel Feb 12, 2013 @ 7:15am
Choppy Animations
Age of Wonders: Shadow Magic is running with fairly choppy animations. The weird part about it is, it seems to work fine until I start a game.

What I mean by that is, the swirl around the menu options is perfectly smooth, suggesting that the game's animations are - at some point - working fine. When I start a game, all of the animations are choppy - units, environment, everything (even though my framerate never drops below ~200). If I then return to the main menu, that perfectly smooth swirl, which was fine, has also become choppy.

I even did a video capture so that you can see exactly what I'm talking about, here: http://www.youtube.com/watch?v=M0tajyi2Kuw. It's obviously nothing game-breaking, but it's still incredibly annoying especially when it ran fine for so long (sadly I don't remember what I might have changed between when it worked and didn't work).

I'm using an nVidia GTX 570, on Windows 7 64-bit. This is using a fresh installation from Steam, after installing the community 1.4 patch (though I was experiencing this same choppiness before installing the 1.4 patch as well). I've tried enabling/disabling pretty much everything on the configuration page as well, as well as set the game to run in Windows XP compatibility mode and run the game as Administrator. I even tinkered with CPU affinity, and downloaded and installed a DirectX 9.0c distribution (June '10) since I recently reinstalled Win 7 and thought that might be the issue.

Any help would be very appreciated. I'm trying to do a video review/tutorial for new players, and want to get this sorted out beforehand so the game looks as good as possible.
Showing 1-5 of 5 comments
< >
Ravel Feb 12, 2013 @ 1:51pm 
I found out the issue! Turns out my computer just needed a restart, and subsequently I feel ♥♥♥♥♥♥♥♥ :P. I remembered an issue with NWN2 where the game would stutter if you hadn't restarted your computer in a little while, and it seems I was suffering from a similar issue here.

Here's what it looks like now: http://www.youtube.com/watch?v=dWqo3L36mU4 (although there is still a *little* bit of stuttering from the video capture software, but overall it's much better)
Godwin  [developer] Feb 16, 2013 @ 6:36am 
It might be that you're using OpenGL. Try turning OpenGL off, I had some issues with the game as well until I tried that.
Oh and enable Direct3D in the configuration.
MikeyTWolf Feb 17, 2013 @ 4:38am 
HOLY ♥♥♥♥ SOMEONE IS BREATHING DOWN HERE!
HEY!
YOU!
DO YOU LIKE THE AI? I'D LIKE TO NOT HAVE AI. WANT TO JOIN ME? THERE'S NOT MANY GAMES OUT HERE RECENTLY, I'M KINDA BORED.
WOULD RATHER STEAM GROUP OR SOMETHING JUST SAYING.
Godwin  [developer] Feb 17, 2013 @ 7:24am 
There's a steam group for the game already, if you join that one (it's open) you'll have a good chance of being able to play it with people. (just search for age of wonders multiplayer in steam groups).
MikeyTWolf Feb 17, 2013 @ 7:45am 
Yeah found it, but does look a bit quiet. I'm still learning how to play really, got a bit of a peaceful city building side over a militaristic side, but I keep stumbling into the god damn Lich and getting all my scouts beat, then overwhelmed as the undead enroach from the fog of war. And this is easy.

Also for some reason I suddenly find myself unable to build buildings I was just able to do so e.g. city grown, now I can get a builders hut then a - hey wait, all the options just vanished. Weird.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50