Eezak Dec 7, 2012 @ 9:35pm
AoW:SM on Win 7 Pro 64-bit
Anyone else running AoW: SM on Win 7 64 bit? I've tried the various compatibility modes (as well as "straight up" Win 7) as well as the Win XP virtual machine in Win 7 Pro. Can get as far as selecting the tutorial or the elves scenario from the menus, but as soon as I try to launch the actual game it crashes immediately to the desktop. I am running as Admin. Any other suggestions? Seem to be finding a lot of my older games that would run fine under Win XP need a lot of tinkering to run under Win 7 if they'll run at all. I'll probably just set up a dual boot system as a relatively easy global fix.
Showing 1-7 of 7 comments
< >
TheBird Dec 8, 2012 @ 11:48pm 
I got my copy to work after I selected "English" in the language drop-down box in the configuration window. I do not have to run it as administrator or use any other compatability settings for it to run correctly.

Your problem may be different from mine as I couldn't even get to the menus or anything.

I am using Windows 7 Pro 64-bit like you are.
Eezak Dec 9, 2012 @ 12:07am 
Was able to run the game not long after I posted my problem here. On another attempt to run the game, SM, a message popped up saying something like..."This program crashed the last time it ran because it wasn't run with the correct compatibility settings. Would you like to run the program now with the correct compatibility settings?"

I clicked "yes" and the game ran fine and just started it up a few minutes ago and it's still working, so keeping my fingers crossed.

Thanks for the info about your discovery, TheBird. Will keep that in mind if I have additional problems.
fista1 Jan 6, 2013 @ 8:35am 
I had this problem too. I unchecked the "Use Direct3D" option in Configuration. That solved my problem.
Ravel Feb 19, 2013 @ 7:52am 
Originally posted by clairne:
I had this problem too. I unchecked the "Use Direct3D" option in Configuration. That solved my problem.

I had a similar issue which was fixed by unchecking Use Direct3D as well.

Later I was able to get the game working with Direct3D by launching from a shortcut to the game's .exe file, instead of launching the game through Steam. This is useful because things like spell AoE indicators are unavailable without Direct3D.
dan04_04 Feb 28, 2013 @ 12:45am 
There seem to be several variances of this issue, some others have had luck starting the game in windowed mode instead of full screen, myself included. Just wanted to add another option here if more come looking.
SephiriotH Feb 28, 2013 @ 6:09am 
I do have Use Direct 3D cheked and game runs ok. Yes, I'm on Win7 64 bit, I did, however some tweaks to main executable file compatibiliy straight before the first launch (such as Run as Administrator, Disable Desktop Compositions, and of course Run in Win98 SP3 compatibility mode) :}
Bean Sídhe Aug 22, 2013 @ 3:33am 
Thank you! I tried all possible ways, and only run of the game in windowed mode helped me!
1. For some games you need to install http://www.microsoft.com/ru-ru/download/confirmation.aspx?id=5549 Games for Windows - a set of dll libraries.
2. Go into the folder with the stim: "C: \ Program Files (x86) \ Steam \ steamapps \ common" folder and open it to the desired game.
3. Create a shortcut ekzeshnika this game on your desktop
4. Click the right button, click Properties, click the Compatibility tab, and tick the box compatibility with WinXP SP3
5. Start Steam and then the game.
Last edited by Bean Sídhe; Aug 22, 2013 @ 8:07am
Showing 1-7 of 7 comments
< >
Per page: 15 30 50