Age of Wonders: Shadow Magic

Age of Wonders: Shadow Magic

Why there is only one display mode in configuration? No full screen?
Also after starting the game, when I click setting and video, there is only one option which is window. Occasionally, suddenly, several other optiosn including full screen pop up and I can swithch to full screen. However, when I restart the game, it again goes back to windowed. Arghhh. Any suggesions to play full screen? I dont mind playing 1024* 920. I dont like windowed mode. (I am using Windows 8)

For your reference, my cd version of the game has no problem starting in full screen rather than in windowed mode
< >
Showing 1-7 of 7 comments
Operations Jun 7, 2014 @ 7:22pm 
I just ran the configuration tool set it to 1920x1080 and it ran full screen.
If you not seeing the option for that, click to play from your steam library, not the desktop shortcut.
I have done that but the only option in the configuration is 'windowed'.
(So after clicking play I chose configuration and above is what happened)
Operations Jun 8, 2014 @ 8:05am 
OK I thought you were starting the game then going to video settings, but you were starting the configuration tool.
What resolution are you trying to play in anyway?

I had a look to see where the settings were stored, but couldn't find a config file.
Found them in the registry here.

HKEY_CURRENT_USER\Software\Triumph Studios\Age of Wonders Shadow Magic\Video

So depending on how confident you are about editing the registry you can try setting the resolution directly.
Display Mode should be for full screen, 1=true (fullscreen) 0=false (windowed)
Display Height, Display Width is the resolution, make sure you dont enter as a hexidecimal value.

I am using windows 7, though the location should be the same for windows 8.
Last edited by Operations; Jun 8, 2014 @ 8:24am
Thank you for your tip
It now works when I followed your advice.

1. I edited the registry to have value of 1
2. Then I started game in the compatibility mode
3. It workS!!

Note)still configuration only shows windowed mode
Note2) if you start the game by clicking play without clicking compatibilit mode, game crashes
Edelward Jun 25, 2014 @ 4:19am 
Have the same problem
Nomad Jun 25, 2014 @ 10:37pm 
I ran into this too, forgot to set the file shortcut/executables to WinXP SP3 Compatability Mode.
Last edited by Nomad; Jun 25, 2014 @ 11:09pm
Edelward Jun 26, 2014 @ 1:48pm 
compability has helped.
< >
Showing 1-7 of 7 comments
Per page: 15 30 50