No_1_Lives_4ever Jan 26, 2013 @ 10:13am
SWRC not even running (Windows 7 64-bit / ATI Mobility Radeon HD 4670 video card)
This is a game that I used to play when I was a kid. I love it! I have lost my CD so I decided buy this game from steam. After I installed the game, when I try to run it, I can see the republic commando start-up but then the game crashes. No error messages or anything. I can not even get to the menu. Do you have any ideas to how to solve that problem?
Showing 1-3 of 3 comments
< >
NoOneofConsequence Feb 12, 2013 @ 9:11am 
I'm in the same boat actually. Different radeon card, but same result. It used to work, but now it doesn't? I rolled back my drivers after an update, and I still get the same result...starts up, then crashes back to the desktop....
Exolutions Feb 14, 2013 @ 2:10pm 
I got Nvidia and Intel Core duo. It's not running. Same problem like you. The game was so good :3 now it doesnt run :(
Rush Rage Feb 14, 2013 @ 7:48pm 
Hmm, works for me...

Win 7
AMD Turion proccesor
ATI Mobilaty Radeon HD 4250
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 26, 2013 @ 10:13am
Posts: 3