zoombi-89 Sep 16, 2013 @ 4:57am
Obsessive Collector bug (?)
Hi folks,

I saw others complain about this as well, but there was no thread for it.
So this achievement: Obsessive Collector (Discover more of Feyre's picturesque history - 47 pcs) seems to be bugged. In the first few minutes I found 11/47 (items in the museum, name plates), but ever since that this number has stopped. I am at 90% now but still at 11/47. This must be obviously a bug/glitch, the question is, if there is any way to make it work.
Showing 1-8 of 8 comments
< >
zoombi-89 Sep 16, 2013 @ 11:56am 
OK, this problem was solved as I completed the game, I got the achievement. But now The Whole Story is bugged :D I recieved it but as I click on the achievements it says it is only 20/21
Mallior Sep 17, 2013 @ 5:02pm 
Hi. As i see somewhere the achivement counter stop. For example Clear out Harvey...bought around 20 stuff, but 6 count :) Sometimes i check that Obsessive Collector, and yeap, i pick up 3 piece, but 1 count...interesting i hope i will get the perfect game. 60%, but doing everything from a guide
So you say that you got the steam achivement? Even if it 20/21? :P
zoombi-89 Sep 18, 2013 @ 4:40am 
Hi,
Yes, I completed the game at 96% and I received the notification of the completion of the Whole Story. Clicking on my achievements it said I don't have the Whole Story because I have only 20/21 (although there were no more things to do in the quest log).
But after a day this problem solved itself (?) and now I have all the achievements. So don't worry, you will get all of them, just give it some time! :)
Mallior Sep 18, 2013 @ 7:59am 
Okay :) Thanks the info.
Hopefully i will finish it today :P
Mallior Sep 18, 2013 @ 1:27pm 
Aaaaand done.
But as i saw Wholy story 20/21 than i whatched the tv....if you have conversation after every map, you got the achivement.
I am sill have the Alphonse treasure quest which given me bye Harvey. But have 100% achivments cheer*
zoombi-89 Sep 18, 2013 @ 2:13pm 
hey, congrats! :)
AnesthesiaCG Dec 20, 2013 @ 8:17am 
I have completed the game, but am missing this badge. My progress always says 0/47. It has been over a year since I completed the game. Maybe I'll replay it to see if that works. Hopefully I will have forgotten the levels.
zoombi-89 Dec 20, 2013 @ 11:15am 
Yeah, maybe you can give it a try and complete it again as long as you enjoy it. And if you don't, you can still open a ticket about it - although Steam support never actually replied to any of my queries :\
Showing 1-8 of 8 comments
< >
Per page: 15 30 50