Tropico 4

Tropico 4

View Stats:
Tropico 4 > General Discussions > Topic Details
Lord Dooba Mar 30, 2013 @ 3:00pm
Tropico 4 won't start after nvidia driver update
I updated my nvidia drivers to enhance my Bioshock: Infinite gameplay. However, after doing so, Tropico 4 would not start. It would get past the Kalypso launcher, show a brief Tropico splash screen, then go to a black sceen with the Tropico style cursor and stop. It did not crash, just hangs. nVidia GeForce 560Ti card, 64 bit system. I upgraded from ver. 306.97 to 314.22 as they recommended.

Solution: Rolling back the drivers solves the problem. I'm hoping it doesn't affect Bioshock too much as I have not finished the game yet. I just have Bioshock on Medium settings anyway because I like a nice framerate and it looks great. Just thought I would share in case others are having this problem.
< >
Showing 1-11 of 11 comments
joboyogi Mar 30, 2013 @ 11:23pm 
I have the same issue with the 660Ti in a 3 monitor setup. It appears to actually shift my monitors over as well.
Desert Canuck Apr 1, 2013 @ 7:07pm 
same with 650M...
MikeH (Banned) Apr 1, 2013 @ 7:16pm 
These are pretty new and awesome graphic cards. Almost sounds as if Tropico needs to update something to handle the newer stuff.
mundox Apr 2, 2013 @ 9:44am 
GTX 560 here, same issue.

Workaround: Disable steam overlay for tropico.
Last edited by mundox; Apr 2, 2013 @ 9:49am
Lord Dooba Apr 2, 2013 @ 9:49pm 
Originally posted by mundox:
GTX 560 here, same issue.

Workaround: Disable steam overlay for tropico.
hmmm... interesting. That could be what the problem really is. I did notice the place it seems to hit a wall is right before the steam overlay pops up.
sinutzu Apr 3, 2013 @ 1:21am 
How exactly do you disable that ? i haven t founf anything remotely related..
MikeH (Banned) Apr 3, 2013 @ 4:00am 
I only use the overlay to check time. There are articles that certain games with certain video drivers will make it so your game won't run. I am surprised that the newer video cards for desktops have issues.

@ sinutzu

In Steam/ Games/ View Games library/ "your game name" right click/ properties/ general tab/ Enable steam communities In-Game. (UN-check this box)
Lord Dooba Apr 3, 2013 @ 7:31pm 
yep that was the culprit. Reloaded the new drivers, disabled in-game and Tropico starts. Thanks for the help everyone.
Hard Boomer Apr 4, 2013 @ 5:14am 
635M happens nothing on launch... Driver: 314.22, also in-game overlay disabled.
Last edited by Hard Boomer; Apr 4, 2013 @ 5:14am
MikeH (Banned) Apr 4, 2013 @ 6:56am 
Laptops do not like this game.

1) add this to host file. see if you can bypass the launcher. (need computer restart)
127.0.0.1 launcher01.kalypsomedia.com

2) start game in win98/me compatibility mode.

3) install dx again. A copy can be found in your team tropico 4 folder. 635M supports DX 11 also. Make sure it's fully updated.

4) switch to run in integrated graphics If the game loads, you know it's the 635M
also try disabling your integrated graphic card in the bios making it 635M dedicated. This will shorten battery life of course, but worked for some with steam game issues.

5) change graphic driver . Sometimes older versions work.

6) Think about running your games on a desktop. Unless it says Alienware on your laptop, your going to run into issues with some games.

rwatts518 Apr 4, 2013 @ 3:54pm 
wow, i feel lucky. i play this on my Qosmio lap. gtx560m v. 310.90
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Tropico 4 > General Discussions > Topic Details
Date Posted: Mar 30, 2013 @ 3:00pm
Posts: 11