Broken Sword 1 - Shadow of the Templars: Director's Cut
ruvyn Apr 28, 2014 @ 8:27pm
Anyone with mouse position problem?
On the menu screen (right after the logo), the cursor won't go down below the 'New Game' icon. I can't get the cursor to 'Options' or 'Quit' icons.

When I choose 'New Game', the problem remains. The cursor won't go into the whole lower portion of the game screen. Since it's point-and-click adventure, clearly I cannot play this game properly.

Anybody with same problem? Any solutions, please?
Showing 1-15 of 17 comments
< >
Mitko Apr 29, 2014 @ 1:57pm 
I have the exam same problem - in Linux, haven't tried any other OS. It would be really great if somebody comes up with a solution.
zole May 1, 2014 @ 6:54am 
do not activate 'augmented' under screen resolution, if you allrady did it delete /.bs1dc/SETTINGS.ELA in your home folder
Last edited by zole; May 1, 2014 @ 7:05am
Mitko May 6, 2014 @ 1:51pm 
Unfortunately, the fix proposed by zole doesn't work for me. I never activated 'augmented', I can't even get to the options menu, since my cursor won't reach it. Deleting the file makes no difference. Neither does reinstalling the game.

Any other ideas?
Baffski May 9, 2014 @ 3:10pm 
I have the same error. Running in windowed mode. First start.
So_Much_For_Subtlety May 11, 2014 @ 6:30am 
I had this problem after selecting augmented but deleting SETTINGS.ELA resolved it for me.

@ zole: Thanks :)
vanar sena May 14, 2014 @ 9:48am 
Thanks, the tip worked for me too. Shame we can't run in it double-size mode without this problem cropping up. The full-screen doesnt appear to work for me at all, as it comes up halfway across my dual monitors, instead of completely in one.
SyXbiT May 15, 2014 @ 10:32am 
I was really excited when this was released on Linux..... but I have the same mouse problem.
N.Korea May 24, 2014 @ 9:17am 
Originally posted by SyXbiT:
I was really excited when this was released on Linux..... but I have the same mouse problem.

Run the following command in $HOME/.bs1dc directory:

cp SETTINGS.ELA SETTINGS.ELA.bak && dd if=/dev/zero of=SETTINGS.ELA seek=83 bs=1 count=2

It will reset your resolution to original. Augmented seems to work only when launched directly, not through Steam.

=========================

UPDATE: If you don't have SETTINGS.ELA in $HOME/.bs1dc directory, don't try to execute dd command alone or you'll end up with 0-filled, probably broken config. Instead run the game directly:

cd $HOME/.local/share/Steam/SteamApps/common/Broken\ Sword\ Shadow\ of\ the\ Templars/ && ./BS1DC

Go into options, change screen resolution to original or fullscreen and exit. From then on you can launch the game from Steam.
Last edited by N.Korea; Jul 23, 2014 @ 1:27am
Mitko May 25, 2014 @ 9:08am 
Originally posted by ǶƝ:
Originally posted by SyXbiT:
I was really excited when this was released on Linux..... but I have the same mouse problem.

Run the following command in $HOME/.bs1dc directory:

cp SETTINGS.ELA SETTINGS.ELA.bak && dd if=/dev/zero of=SETTINGS.ELA seek=83 bs=1 count=2
.
It will reset your resolution to original. Augmented seems to work only when launched directly, not through Steam.

Thanks ǶƝ, that actually helped. I can even change to augmented after I launch the game and it works fine, at least for the current session. I have to repeat the fix if I leave the game while using the augmented setting.
Zéfling Jun 13, 2014 @ 1:23pm 
It does not work for me and $HOME/.bs1dc is a empty forlder...

Edit : if the folder is empty use only :

dd if=/dev/zero of=SETTINGS.ELA seek=83 bs=1 count=2


Last edited by Zéfling; Jun 13, 2014 @ 1:26pm
pecosdave Jul 4, 2014 @ 11:40am 
Originally posted by ǶƝ:
Originally posted by SyXbiT:
I was really excited when this was released on Linux..... but I have the same mouse problem.

Run the following command in $HOME/.bs1dc directory:

cp SETTINGS.ELA SETTINGS.ELA.bak && dd if=/dev/zero of=SETTINGS.ELA seek=83 bs=1 count=2
.
It will reset your resolution to original. Augmented seems to work only when launched directly, not through Steam.

Worked for me, certainly easier than the convoluted lowering my system resolution first trick I came up with on my own.
pecosdave Jul 4, 2014 @ 12:11pm 
Upon further investigation the SETTINGS.ELA fix causes sound problems for me and adjusting the sliders didn't fix it. Also there were weird mouse issues for me, I would have to click the window, then click an object, it was unreliable.

What DID work for me was I lowered my screen resolution to 720x480, I was then able to click anywhere on the window. The game was defaulted to Original since the X Server was at such a low setting. I selected Full Screen, everything worked great, I exited the game, put my resolution back to 1920x1200, re-entered the game, set the game back to Augmented, it works fine.
kureshii Aug 23, 2014 @ 3:53am 
Originally posted by ǶƝ:
UPDATE: If you don't have SETTINGS.ELA in $HOME/.bs1dc directory, don't try to execute dd command alone or you'll end up with 0-filled, probably broken config. Instead run the game directly:

cd $HOME/.local/share/Steam/SteamApps/common/Broken\ Sword\ Shadow\ of\ the\ Templars/ && ./BS1DC

Go into options, change screen resolution to original or fullscreen and exit. From then on you can launch the game from Steam.

Worked great for me, thanks!
[wrd] Aug 26, 2014 @ 1:17am 
entering and leaving fullscreen worked for me. (pressing alt+enter twice)
Last edited by [wrd]; Aug 26, 2014 @ 1:17am
I►► R Oct 1, 2014 @ 9:01pm 
Originally posted by zole:
do not activate 'augmented' under screen resolution, if you allrady did it delete /.bs1dc/SETTINGS.ELA in your home folder
Kudos!
Showing 1-15 of 17 comments
< >
Per page: 15 30 50