Acryl Oct 28, 2012 @ 2:07pm
Windows 8 not compatible with Games For Windows Live!!
Hi, it is not possible to install the "Windows Live ID Sign-in Assistant" on Windows 8. According to Microsoft support, Games For Windows Live (GFWL) is not supported on Windows 8 anymore!! This is terrible! Now I am not able to connect to GFWL when starting Batman Arkham City! So I have NO ACCESS to my in-game profile including all my savegames! IMHO this is not acceptable!
Showing 1-15 of 26 comments
< >
thekeyman77 Oct 28, 2012 @ 2:14pm 
What does GFWL stand for?
dcholmes1969 Oct 28, 2012 @ 7:51pm 
It stands for Games For Windows Live
Jambo Oct 29, 2012 @ 2:06am 
it does work! you can download it.
I have windows 8 and im playing batman arkham city on it with my old save files and can still access GFWL.
Last edited by Jambo; Oct 29, 2012 @ 2:07am
Jager Bombs Away Oct 29, 2012 @ 8:09am 
I'm having the same problem. I can't utilize any of my old saves nor can I save any new games on Win 8. What did you download to make this work. I have GFWL on my desktop but that doesn't give me access to save.
Acryl Oct 29, 2012 @ 3:53pm 
Solved the problem! I had to do these steps:

- Open "Programs and Features"

- Uninstall all entries starting with "Microsoft Games For Windows..."

- Then ONLY reinstall latest version of "Games for Windows Software Setup" aka gfwlivesetup.exe, there is NO NEED to reinstall the Assistant!

I also know what the root cause of the problem was: When you install Batman Arkham City it installs an OLD version of the GFWL client not working with Windows 8. So you have to deinstall the old crap and then install the new version!

Works like a charm now with Batman Arkham City on Windows 8!
Inso Oct 30, 2012 @ 7:42pm 
All I can find is V3.5 from march 2011, which causes the same problems then the one Steam installed
Conkerkrusher Oct 31, 2012 @ 10:47am 
You are looking in the wrong spot for the update

http://www.xbox.com/en-US/Live/PC/DownloadClient

Uninstall gfwl then use that link. It fixed all my gfwl titles.
SamFinn Oct 31, 2012 @ 1:22pm 
I got that version and it still dont work for me. Out of all my GFWL games its the only one that wont work.
Last edited by SamFinn; Oct 31, 2012 @ 1:26pm
Conkerkrusher Oct 31, 2012 @ 2:58pm 
did you uninstall the old versions first? if not it wont work correctly
SamFinn Oct 31, 2012 @ 4:01pm 
I have tried allsorts, Mine is not the steam version though it is the retail. So im wandering if the base game needs updating first, and as it updates through GFWL im a bit stuck.

Does the steam version update through GFWL or through the steam client?
asdf Oct 31, 2012 @ 11:25pm 
Originally posted by SamFinn:
I have tried allsorts, Mine is not the steam version though it is the retail. So im wandering if the base game needs updating first, and as it updates through GFWL im a bit stuck.

Does the steam version update through GFWL or through the steam client?

Same problem here with Windows 8 and the retail version of Arkham City.

When I install the game everything is fine, no matter what the GFWL client is. But the game needs to update through GFWL. After the update it asks me to restart the game, but then GFWL won't pop up anymore, can't sign in to my profile.

I installed Arkham Asylum too and guess what, it's working without any problem !

If someone knows how to fix this please help !
SamFinn Nov 2, 2012 @ 7:28am 
I have a solultion that works for me. It needs properly sorting with a patch or driver, but if you start the launcher and scroll right to the bottom and disable Physx, GFWL will start and the game can update and you can use your saves.
John Nov 4, 2012 @ 7:00am 
I can not get the Retail (non-steam) version working on Windows 8 PRO. The GFWL on the Disc would not install, but the game install just fine. I could not start the game without receiving an error about xlive.dll. I downloaded GFWL from the web, and installed successfully. Now when I go to start Batman Arkham City, I get the launcher, but when I click play it just loops back around to a new laucher window.

I am extremely dissapointed that the retail version could not be activated through Steam. I will never buy another GFWL game.
Nov 5, 2012 @ 6:24am 
Yep, cant login to Games for ♥♥♥♥ here neither. Guess thats the last game i bought with this ♥♥♥♥ on it.
SamFinn Nov 5, 2012 @ 7:11am 
1. Uninstall Microsoft Games for Windows Live Redistributable and marketplace from control panel - programs and features.

2. Download Client from here. http://www.xbox.com/en-GB/LIVE/PC/DownloadClient

3. use the batman launcher and go into settings

4. disable physx completely

5. Launch batman and GFWL should run

If you do not disable Physx the game will launch without the client.
Showing 1-15 of 26 comments
< >
Per page: 15 30 50