CrazyF1r3f0x Dec 27, 2012 @ 8:05pm
Game not launching
Game installation went over fairly smoothly, after launching the game a prompt requested my CD, which I supplied, it read the key as legitimate; however and issue occurred when attempting to play the game. That issue being that nothing happens, no popups, nothing; the only change is steam shows that I am playing "batman arkham city goty" for about 10 seconds, then goes back to its regular state.

So far I have been reading everything on these forums that I can, but no solutions. I've updated my drivers, I've made sure DXdiag reports no problems with DX; I've re-installed GFWL, and AC; and done plenty of reboots, but to no avail.

At this point I'm honestly stumped, does anyone have any idea what is wrong?
Last edited by CrazyF1r3f0x; Dec 27, 2012 @ 8:07pm
Showing 1-3 of 3 comments
< >
mbrierley Jan 20, 2013 @ 10:17pm 
make sure you're signed into a microsoft windows live account. (xbox live account).also there might be some missing files you didnt download. try right clicking on the batman game in your library, then press properties. click on local files and then intergrity of game cache. it will see if you have any files missing. hope this helps.
CrazyF1r3f0x Jan 21, 2013 @ 12:12am 
No luck with logged into my account; same effect when I launched the game. This was after I had verified my cache, which steam reported as 100% valid.
ServiusTheBear May 1, 2013 @ 12:30pm 
Right I have had this problem to. I contacted the makers and they say my system does not met the requierments. Even tho i pass the minimum
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Dec 27, 2012 @ 8:05pm
Posts: 3