Hector Salamanca 2012年10月6日下午12:34
Amnesia
I am stuck in a part of amnesia in which u must place a pot of explosive elixir in front of a large blockage of boulders in front of the machine room.What must i do in order to get past it is their some sort of mechanism that lights it or something else someone help. and also my last one about amnesia was bad because i did not know what this page of steam was for sorry about that!
正在显示第 1 - 9 条,共 9 条留言
< >
JuicySquid 2012年10月6日下午3:05 
I think you can just throw a rock at the elixir and it will explode within a few sec. Just make sure to take cover until it explodes.
ILLIONAIRE 2012年10月6日下午10:44 
oh i thought u get a tinderbox to light it lol
Hector Salamanca 2012年10月7日上午7:11 
see thats what i thought and i tried but it did not give me the option
Bojack Horseman 2012年10月7日下午12:12 
I had a problem with that too...Go to the top of the stairs and throw stuff at it. Once its lit....RUN
Hector Salamanca 2012年10月7日下午12:18 
thanks
ill try that when my mirrors edge download is finished
TMAC Blade 2012年10月9日上午3:03 
to be honest you would think a tinderbox but no instead a random bone you throw at it will. I have heard of chemicals reacting to constant movement but if you are playing this for the first time you will not think throwing a bone or a rock would make a flamibale liquade ignite
Hybelkaninen 2012年10月9日下午1:14 
A little off-topic but...if I remember correctly, a type of Nitroglycerin is highly unstable to such an extent that it may go off by movements/vibrations.
Hector Salamanca 2012年10月18日下午6:54 
thaks guys im not sure how to end a topic so this is done i guess
Collisto 2012年12月11日上午9:35 
all i did was hit the thing and it lit, so i ran, and survived! likeaboss
正在显示第 1 - 9 条,共 9 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年10月6日下午12:34
帖子数: 9