Hector Salamanca Oct 6, 2012 @ 12:34pm
I am stuck in a part of amnesia in which u must place a pot of explosive elixir in front of a large blockage of boulders in front of the machine room.What must i do in order to get past it is their some sort of mechanism that lights it or something else someone help. and also my last one about amnesia was bad because i did not know what this page of steam was for sorry about that!
Showing 1-9 of 9 comments
< >
JuicySquid Oct 6, 2012 @ 3:05pm 
I think you can just throw a rock at the elixir and it will explode within a few sec. Just make sure to take cover until it explodes.
クリスJ Oct 6, 2012 @ 10:44pm 
oh i thought u get a tinderbox to light it lol
Hector Salamanca Oct 7, 2012 @ 7:11am 
see thats what i thought and i tried but it did not give me the option
Wode The Rootin Tootin Cowbo Oct 7, 2012 @ 12:12pm 
I had a problem with that too...Go to the top of the stairs and throw stuff at it. Once its lit....RUN
Hector Salamanca Oct 7, 2012 @ 12:18pm 
ill try that when my mirrors edge download is finished
TMAC Blade Oct 9, 2012 @ 3:03am 
to be honest you would think a tinderbox but no instead a random bone you throw at it will. I have heard of chemicals reacting to constant movement but if you are playing this for the first time you will not think throwing a bone or a rock would make a flamibale liquade ignite
Hybelkaninen Oct 9, 2012 @ 1:14pm 
A little off-topic but...if I remember correctly, a type of Nitroglycerin is highly unstable to such an extent that it may go off by movements/vibrations.
Hector Salamanca Oct 18, 2012 @ 6:54pm 
thaks guys im not sure how to end a topic so this is done i guess
Leo the frisky cat Dec 11, 2012 @ 9:35am 
all i did was hit the thing and it lit, so i ran, and survived! likeaboss
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Oct 6, 2012 @ 12:34pm
Posts: 9