escoates2003 Jan 6, 2013 @ 11:15pm
Amnesia framerate issue
Here are my specs:
Core i3 - First Generation, clocking at 2.13 GHz
Intel HD Graphics
4GB RAM

Have tried multiple solutions to get this game fixed so that it's running smoothly. Watched some videos that people have actually gotten this game to run on their systems with about the same specs as I have with better framerates. Current settings, have most of the advanced options checked off to try to make the game much smoother. The only problem I"m friggen having is whenever I go into the wine cellar, the game becomes extremely slow and I don't know why. Everything else tries to go at a much faster pace but when I get to the wine cellar, the game just bogs down. Does anyone have a solution for this or why it's doing it. I'll post my log here.

Version 1.20
-------- THE HPL ENGINE LOG ------------
Engine build ID 20101021192547

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating generate module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating loader handlers
Creating resource managers
Adding loaders to handlers
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init lowlevel graphics: 800x600 bpp:32 fs:1 ms:0 gpufmt:2 cap:'Amnesia - The Dark Descent - Loading...' pos:(-1x-1)
Setting video mode: 800 x 600 - 32 bpp
Init Glew...OK
Setting up OpenGL
Vendor: Intel
Renderer: Intel(R) HD Graphics
Version: 2.1.0 - Build 8.15.10.2622
Max texture image units: 16
Max texture coord units: 8
Max user clip planes: 6
Two sided stencil: 1
Vertex Buffer Object: 1
Anisotropic filtering: 1
Max Anisotropic degree: 16
Multisampling: 1
Texture compression: 1
Texture compression S3TC: 1
Auto generate MipMaps: 1
Render to texture: 1
Max draw buffers: 8
Max color render targets: 8
Packed depth-stencil: 1
Texture float: 1
GLSL Version: 1.20 - Intel Build 8.15.10.2622
ShaderModel 2: 1
ShaderModel 3: 1
ShaderModel 4: 0
OGL ATIFragmentShader: 0
ATTENTION: System does not support const arrays in glsl!
Setting up G-Bugger: type: 0 texturenum: 3
Adding engine materials
Initializing DevIL
Vendor String: Abysmal Software
Version String: Developer's Image Library (DevIL) 1.6.8pre Aug 12 2006
Version Number: 168
Adding engine post effects
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL
Available OpenAL devices:
0. Generic Software on Speakers (Realtek High Definition Audio)(OpenAL default)
Trying to open device 'Generic Software on Speakers (Realtek High Definition Audio)'... Success!
Number of mono sources: 32
Streaming setup: 4 Buffers x 262144 bytes each
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
--------------------------------------------------------

Game Running
--------------------------------------------------------
-------- Loading map 'menu_bg.map' ---------
Cache Loading: 1662 ms
Entities: 364 ms
Compilation: 1 ms
Total: 2041 ms
Meshes created: 26
Bodies created: 5
-------- Loading complete ---------
Setting profile: 'Nick' Path: 'C:\Users\Nick\Documents/Amnesia/Main/Nick/'
-------- BEGIN LOAD FROM C:\Users\Nick\Documents/Amnesia/Main/Nick/AutoSave_WineCellar_2013_1_5_12_37_29_0.sav ---------
LOADING SAVE GAME!
-------- Loading map '05_wine_cellar.map' ---------
Cache Loading: 1908 ms
Entities: 1031 ms
Compilation: 24 ms
Total: 3295 ms
Meshes created: 221
Bodies created: 45
-------- Loading complete ---------
WARNING: Could not find player start node ''
ERROR: StartPos '' does not exist!
-------- END LOAD ---------
-------- Loading map 'menu_bg.map' ---------
Cache Loading: 1564 ms
Entities: 352 ms
Compilation: 1 ms
Total: 1929 ms
Meshes created: 26
Bodies created: 5
-------- Loading complete ---------
--------------------------------------------------------

Statistics
--------------------------------------------------------
Medium framerate: 17.881934
--------------------------------------------------------

User Exit
--------------------------------------------------------
Saving main config.
Saving user config.
Deleting game modules.
'LuxInputHandler'
'LuxHelpFuncs'
'LuxSaveHandler'
'LuxScriptHandler'
'LuxProgressLogHandler'
'LuxMapHandler'
'LuxMapHelper'
'LuxPlayer'
'LuxInsanityHandler'
'LuxDebugHandler'
'LuxEffectRenderer'
'LuxMusicHandler'
'LuxMusicHandler'
'LuxEffectHandler'
'LuxCompletionCountHandler'
'LuxGlobalDataHandler'
'LuxHintHandler'
'LuxPostEffectHandler'
'LuxPreMenu'
'LuxDebugHandler'
'LuxInventory'
'LuxJournal'
'LuxCredits'
'LuxLoadScreenHandler'
Deleting config files.
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
Deleting all sets
Deleting all skins
Deleting all gfx elements
Deleting all materials
--------------------------------------------------------

Exiting Generate Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
Done with ent files
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
Physics
Sound
Input
Resources
System
Graphics
Haptic
HPL Exit was successful!

|--Memory Manager Report-------------------------------|
|
| No memory leaks detected. Memory left: 0
|
|------------------------------------------------------|

Showing 1-6 of 6 comments
< >
escoates2003 Jan 6, 2013 @ 11:22pm 
Funny thing is, I have played skyrim on my pc just fine, I mean it's a little choppy but not compared to this. I can run skyrim on my pc much more smoother than this game so I'm just wondering what the big deal is or what's causing this to happen.
-.B.O.W.-Killer- -OVERWATCH- Jan 7, 2013 @ 8:20am 
Buy a cheap gpu, Intel HD Graphics is your big problem, its not for gaming only desktop use. Overclocking your pc may help or dropping the latency timings of your ram will also speed up intergrated gpu.
Make sure in your pc bios u have alocated as much ram as possible towards graphics.
Last edited by -.B.O.W.-Killer- -OVERWATCH-; Jan 7, 2013 @ 8:24am
escoates2003 Jan 7, 2013 @ 9:31am 
Ok, I'll check that. Is there anyway to modify settings through a commandline? Because I was able to modify settings with far cry 2 and it works great. I have a laptop so I understand if amnesia just can't run on it.
Last edited by escoates2003; Jan 7, 2013 @ 9:32am
c7raxik Apr 28, 2013 @ 6:11pm 
Hi. Is this framerate issue occures whenever You get to "wine cellar" or is it occures on second or third visit in wine cellar?
Whenever I get to "wine cellar", on start I get a small framedrop but it is only for short period of time (3-5 seconds). And then framerate goes to normal.
But I have found a bug in "wine cellar" and "laboratory" which can eventually screw a game forced You to start a new one. But only if You are a fan of long walking.
It is funny cause I beat the game once, and never experienced this issue. I got the issue on different machine with i5 sandy b., intel HD2500/3000 and Win7 x64 so the first I thought was - intel chip sucks or Win7 x64 sucks.
But then I reproduced the same bad behaviour on the first machine (XP-SP3, AMD 64 X2, GF8600GTS).
When You are going to prepare acid in "laboratory" and take a route to lab first You will find a note that ingredients are in wine cellar. Then each normal player will collect all ingredients.and never return to wine cellar. But if You are lazy You can take only one potion and back in laboratory start to prepare acid. In my case, calamine as second ingredients has screwed a game. When I return for third potion to wine cellar framerate dropped to almost 0, the stairs has dissapeared (collapsed) and there were crates and wooden supports flying in the air. The same has happened when I prepared acid and the stairs in laboratory collapsed.
Here are some screens from wine cellar:
h**p://imageshack.us/a/img23/9640/amnesiaissue1.jpg
h**p://imageshack.us/a/img515/9646/amnesiaissue2.jpg
h**p://imageshack.us/a/img59/4669/amnesiaissue3.jpg
h**p://imageshack.us/a/img600/7605/amnesiaissue4.jpg
h**p://imageshack.us/a/img153/4544/amnesiaissue5.jpg
Mr. Hankey Apr 29, 2013 @ 1:43pm 
Did you try turning edge smoothing & SSAO off?
escoates2003 Apr 29, 2013 @ 9:41pm 
Everything is fixed guys, decided to not be a puss and just build my own desktop. Have a nvidia 650Ti graphics card now with a dual core processor that runs at 3.0Ghz. It's all good now, thanks for helping though everyone!
Last edited by escoates2003; Apr 29, 2013 @ 9:41pm
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Jan 6, 2013 @ 11:15pm
Posts: 6