CyrustheVirus73 May 24, 2013 @ 4:45am
Game crashes whenever I run it!
Whenever I run Amnesia: The Dark Descent, a window called "BlackBox" pops up and says "!!!GAME CRASHED!!! READ THIS: Something is wroooooong! If all fails go to http://support.frictionalgames.com/for mor info".

Below it, there is a box that says Exception reason above it, and it says: "Amnesia.exe caused an EXCEPTION_ACCESS_VIOLATION in module ig4icd.dl at 0023:0A903E22".

If any of you out there have the slightest clue as to why it's doing this, please message me ASAP! Thanks.
Showing 1-15 of 18 comments
< >
GLaDOS May 24, 2013 @ 5:15am 
Its a hpl2 error. show us the hpl.log and we can probably help you!
CyrustheVirus73 May 24, 2013 @ 12:26pm 
Is an hpl.log in the Amnesia files?
CyrustheVirus73 May 24, 2013 @ 1:04pm 
CyrustheVirus73 May 24, 2013 @ 1:26pm 
I found a dll. folder type in the Amnesia folder titled "BlackBox" So I took it out of the folder and put it somewhere else. Whenever I try to run Amnesia, it just says "Amnesia.exe has stopped working".
GLaDOS May 25, 2013 @ 1:01am 
Yes. The Blackbox is a debugpart of hpl2. If you delete it, you won't get any good errors. Instead your OS says: "This programm stopped working." Put the dll back in, please.
To your problem:
Your log-file doesn't show any errors. Just one thing: It doesn't support the GLSL-Shader used ingame. There are 2 possibilities of what you can do: Try to update your graphicscarddriver and hope that will fix it. Or 2.: Use another graphics card.

The problem is not that your chipset is bad, it just doesn't support the way Amnesia is rendered (thats my intension).

Update your drivers and give it a try!
CyrustheVirus73 May 25, 2013 @ 3:23am 
I did, and it didn't work. Oh well, guess i'm ♥♥♥♥ed! Joking, i'm getting a new computer this summer. Thanks for replying!
GLaDOS May 25, 2013 @ 3:50am 
You are welcome.
CyrustheVirus73 May 25, 2013 @ 3:51am 
Sayonara!
rim6o May 25, 2013 @ 5:13am 
Even if you decided to ditch your current rig, it would still be helpful for others (those with the same or similar problems) if you stated at least your graphics chipset. Preferably also the graphics card model, driver version you used... Seeing you mention an exe file I assume you run Windows, not Loinux.
GLaDOS May 25, 2013 @ 5:36am 
You know that it is in the hpl.log-file? He said everything necessary!
GLaDOS May 25, 2013 @ 5:36am 
He uses an Intel Mobile Chipset. Laptopuser?
rim6o May 25, 2013 @ 5:55am 
Originally posted by GLaDOS:
You know that it is in the hpl.log-file? He said everything necessary!
The log states only the family, not the exact model. Intel mobile graphics chipsets differ in both performance and feature sets.

Some more detailed info on my integrated graphics (as an example):

glxinfo | grep renderer
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset

sudo lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Last edited by rim6o; May 25, 2013 @ 6:42am
CyrustheVirus73 May 25, 2013 @ 11:11am 
I have a MobileI(R) 4 Series Express Chipset family.
CyrustheVirus73 May 25, 2013 @ 11:12am 
I don't know the name of the update I downloaded, but it's the most recent update on the Intel website.
GLaDOS May 25, 2013 @ 12:02pm 
Nah... you have one chip of the family...
run dxdiag.exe please and tell us which chipset you use.
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: May 24, 2013 @ 4:45am
Posts: 18