Dota 2 > General Discussions > Topic Details
ANTIPUDKA Sep 24, 2013 @ 11:50am
READ IF YOU CONSTANTLY DC!
This fixed it completely for me. I had the 'steam logon' error.

1. I turned my network quality to low (didn't fix it, but you can try.).

THIS HOWEVER, FIXED IT:
2. I closed off steam, logged off, and deleted ClientRegistry.blob. After that, been playing the entire game without DC's!

I was disconnecting every ~30 seconds. Restarted steam, did this, no longer had any disconnects. :-)

Hope this helps.
Last edited by ANTIPUDKA; Sep 24, 2013 @ 11:52am
Showing 1-14 of 14 comments
< >
REKTangle Sep 24, 2013 @ 11:59am 
So we're back to deleting clientregistry.blob? I didn't have to do that for years. But I can remember when it used to fix many steam problems.
Last edited by REKTangle; Sep 24, 2013 @ 11:59am
ANTIPUDKA Sep 24, 2013 @ 11:59am 
Originally posted by Nyan:
So we're back to deleting clientregistry.blob? I didn't have to do that for years.
I know it sucks, but it fixed it for me.
The Executioner's Bong Sep 24, 2013 @ 12:03pm 
Didnt work for me :(
Darky The Worm Sep 24, 2013 @ 12:14pm 
Doesn't do ♥♥♥♥ I keep getting that ♥♥♥♥ing message, seriously valve ♥♥♥♥ you who cares if I am not on steam get rid of this ♥♥♥♥.
3dge Sep 24, 2013 @ 12:18pm 
Nope, doesn't work for me.
MMR - MeetMoreRetards Sep 24, 2013 @ 12:21pm 
Does it actually work? I just had a match where I got it for the first time ever.
Honk Honk Sep 24, 2013 @ 12:32pm 
it worked for me, for around 5 mins -.-
Barry Scott Sep 24, 2013 @ 12:37pm 
Originally posted by Honk Honk:
it worked for me, for around 5 mins -.-
+
Nussi is good! Sep 24, 2013 @ 12:39pm 
Nope, doesn't work for me either
MMR - MeetMoreRetards Sep 24, 2013 @ 12:41pm 
Apparently this problem also ♥♥♥♥s with tf2. I was playing tf2 because my dota got ♥♥♥♥ed by this no steam logon and tf2 also says something similar with "steam authority" gg
seventeeN Sep 24, 2013 @ 12:41pm 
Didn't work and i have the same issue.
2 games in a row, I get disconnected every 2 minutes, NO STEAM LOGON. Had 1200 games and no abandon, just made my first 2, urged by my team. I uninstalled the game, not coming back to it. gj valve
Sahlokniir Sep 24, 2013 @ 12:43pm 
Also got my first 2 abandons after 100 hours of gameplay.

Guess we have to wait untill the matter gets fixed, I've read that this always happens after a big update.
Fallyx Sep 24, 2013 @ 2:57pm 
WOW! It worked for me. Thank you very much!!!!!
MaNNeQuN Sep 24, 2013 @ 3:46pm 
beter fix my report
Showing 1-14 of 14 comments
< >
Per page: 15 30 50
Date Posted: Sep 24, 2013 @ 11:50am
Posts: 14