Left 4 Dead 2 > Beta Feedback > 主题详情
Eric 2013年5月5日下午2:51
Linux Issues So Far
I really appreciate the Linux support. I bought the Valve complete pack to encourage you.

I'm running Ubuntu 12.04 LTS x64 with Gnome 3. I've got a AMD Radeon HD 6800 running 3 1920x1200 displays. I'm running the latest Catalyst 13.4 directly from the AMD website.

Here's the issues I've seen thus far:
* Crash to desktop on second level (streets) of first campaign.
* Hang when changing video settings. The audio stutters, and sometimes if you wait a couple minutes it comes back to life.
* Subtitles show the translucent box, but no text. I've seen it work once or twice, but not most of the time.
* Audio settings not saving, keeps reverting to headphones.
* The game played at a reasonable speed yesterday on max resolution, highest settings, but today I had bad 6fps, super laggy no matter what settings. After logging out, and back in, I could get resonable performance with highest settings, but at 1440x900.
正在显示第 1 - 15 条,共 49 条留言
< >
lbertolotti 2013年5月5日下午5:03 
Well the games is working but seems to waging, cant change the resolution and cant download some add-ons, yet tf2 work perfectly on my ubuntu. Any ideas?
最后由 lbertolotti 编辑于; 2013年5月5日下午5:09
A'h♥le Shitlеr [linux] 2013年5月6日上午2:45 
So far I haven't got any problems which I didn't have in Windows. I get a cpu-lag every time some new resources is loaded, like a new character shows up the first time after running the game. But I will try later with disabling multicore function, which should maybe fix the problem. Console command/variable: mat_queue_mode 0 (this will force CPU to run with one core, and by some says to fix this (valid for windows as well)) I will give feedback on this when I have tested this.

Else I have i7 9770, 16GB RAM, Intel 256GB SSD (from this year), and nVidia GTX 670.

I played entire first campaign in single player mode yesterday, and it worked with no problem, except the laggy-part I described above. Everything on maximum settings, and always above 120fps, avarage seemed to be ~180fps.
Garve 2013年5月6日上午3:40 
Well, it randomly crashes for me and the performance is still also worse than on Windows (same PC). Can't even get past the first map. Linux Mint 14, KDE, NVIDIA GeForce 250 GTS, latest stable driver. But since it's still a beta that's ok for me. :)
A'h♥le Shitlеr [linux] 2013年5月6日上午8:43 
With "mat_queue_mode 0" it runs way more smooth, yet it has some slight lag some few times. Very playable, and just minor annoyance.
lbertolotti 2013年5月6日上午11:01 
k how about that for the console : An error occurred while attempting to download a file from the UGC server!
when trying to download add-ons, good u mentioned the console, there seems to a huge number of errors in it
最后由 lbertolotti 编辑于; 2013年5月6日上午11:02
Linux Power 2013年5月7日上午9:43 
For me, the real problem now is the latency going at 700 ms. When it comes to performance, it is nearly perfect. AMD Radeion 7730m running with 13.04 drivers i7 2.1ghz 750go 7200rpm hdd
lbertolotti 2013年5月8日上午6:15 
what resolution are u guys playing with?
最后由 lbertolotti 编辑于; 2013年5月8日上午6:15
A'h♥le Shitlеr [linux] 2013年5月8日下午12:46 
I'm playing with 1920x1080
scooley138 2013年5月29日下午7:47 
1920x1200 gtx 460 phenom II 4x 3200mhz 8gig ram (archlinux). Game runs smoothly for the most part, however sometimes it will suddenly slow down to about 1fps, the sound will stutter terribly (like a broken record) and game time slows down too. This is NOT normal slowdown due to CPU or GPU being underpowered or something. This may be the same problem that A'hole was describing above, but I don't know.

When I hit ESC to enter the options menu, the problem persists. When I (patiently) go to graphics settings, and change the resolution (doesn't matter if I change the res up or down) the problem goes away. Sometimes instead of the problem going away, it crashes back to the desktop.

Also, sometimes when I first beat a level, I get a crash to desktop.

By the way, I haven't tried it with multicore disabled yet.
最后由 scooley138 编辑于; 2013年5月30日上午6:52
scooley138 2013年5月29日下午8:15 
Nope, turning off multicore rendering did not help.
A'h♥le Shitlеr [linux] 2013年5月30日上午8:02 
After last update, I actually had no issues whatsoever. Dunno if disabling multicore rendering is still necessary or not, but atm. it works smoothly with no issues, no more lag. But as others still have the problem, I can't help with any other ideas. But it's still in beta, and it's probably a reason for that ;]
scooley138 2013年5月31日下午1:22 
It's probably a separate issue then. I can confirm that it's still happening to me. May be a certain special effect triggers it or something.
zlatan.todoric 2013年6月20日下午6:54 
I have RadeonHD 7470M 1GB, 8GB RAM, AMD Brazos Dual-Core E450 processor ... - the game lags, I have set resolution on my monitor to 1024x768 (4:3) and it still when going through games has every few second (or few movements) a lag/hang for about sec and it goes on...on Windows it was all okay... driver is latest fglrx 13.4...I am on Debian Testing, changing video setting (except resolutins) hangs game totally. But still being beta and all this changes - good job Valve, very good job :)
A'h♥le Shitlеr [linux] 2013年6月21日上午8:25 
引用自 zlatan.todoric
I have RadeonHD 7470M 1GB, 8GB RAM, AMD Brazos Dual-Core E450 processor ... - the game lags, I have set resolution on my monitor to 1024x768 (4:3) and it still when going through games has every few second (or few movements) a lag/hang for about sec and it goes on...on Windows it was all okay... driver is latest fglrx 13.4...I am on Debian Testing, changing video setting (except resolutins) hangs game totally. But still being beta and all this changes - good job Valve, very good job :)

Did you try the above fixes? It may help for some (like me), worth a try if you didn't ;]
Garve 2013年6月21日上午9:20 
Still crashing at random. I can't even get past the first map of Dead Center in Single Player.
正在显示第 1 - 15 条,共 49 条留言
< >
每页显示数: 15 30 50