Rick James 4. Aug. 2013 um 21:25 Uhr
Help with SRCDS Server
So I'm trying to host a server for me and my friends to play in. I've wanted this kind of server in order to play with more than 4 people. I followed this guide here to do it.

http://www.tunngle.net/community/topic/97791-left-4-dead-2-dedicated-servers-setup-guide-dedicated-server-patch-16-by-sfk-updated-11th-march-2013/

Problem is, everytime I Invite poeple to join, they get a "server not responding" message. I've been able to get it to work in the past so im completley clueless as to whats going on. I've tried port forwarding, allowed all access through firewalls, and even deleted everything and started from scratch, twice, still to no avail. I'm just about ready to give up. Any help with my situation would be greatly appreciated. :D
Beiträge 1-5 von 5
< >
XxZIOIMIBIExX ®™ 5. Aug. 2013 um 2:47 Uhr 
by the looks of it, the only thing wrong is your IP isnt static, its dynamic.
use this.

http://portforward.com/help/setup_static_ip_address.htm

and heres a proper walkthru anyways just in case. :P

make sure to open/forward any port (i highly recommend 27015) on both TCP and UPD in your routers firewall. MAKE SURE you open the same ports on TCP and UDP,

example dont open 27015 TCP and 27016 UDP

open 27015 TCP and 27015 UDP

then make sure your IP is static, i recommend this

http://portforward.com/help/setup_static_ip_address.htm

(your server will not show up in the master server list unless your IP is static.)

then its as simple as clicking the make my IP static button, and that site should also help you immensly if you get lost, but it really is mostly those 2 steps.

after those are done just make sure to download the server files from either steamcmd, or in the tools section in your steam client.

then open up notepad and paste this in it.

echo off
cls
echo SRCDS auto restart
title left4dead2 auto restart
:srcds
echo (%time%) SRCDS started.
start /wait srcds.exe -console -game left4dead2 -maxplayers 4 +map c1m1_hotel -port 27018
echo (%time%) Your server just closed or crashed. RESTARTING!
goto srcds

replace the port with the ports you opened, and leave the rest. then save it as "Auto Server Restart.bat"

this will create a batch file to run the server in console mode (conserves CPU usage)
and if the server crashes it will auto reboot.

put this with the srcds of the L4D2 server.

now to join your server, on the bottom right hand side of your main menu, there will be the "steam group servers" thats the server you want to join, so when setting up your game,
instead of choosing "offiicial dedicated" your going to choose your "steam group server"
(where you choose the map)

an voila cuztom server, i also HIGHLY recommend you checkout sourcemod, and metamod admin mods. because they have some killer plugins for servers, my server has auto health regen, you can give players pipebombs, molies, and bilejars, make the AI use melee weapons, spawn pretty much anything you want any time. and none use the SV_cheats command so you can have fun, and kick ♥♥♥ on expert while still being able to get achievements :)

enjoy man, if you STILL need some help add me and ill walk you thru it ;)
Zuletzt bearbeitet von XxZIOIMIBIExX ®™; 5. Aug. 2013 um 3:06 Uhr
Rick James 5. Aug. 2013 um 22:58 Uhr 
Well, I feel dumb, my IP WAS dynamic. Thanks for the help! But one more thing. I had a friend try to join me and just a while ago after using that program you linked me. He still had a "server not responding" message. I just double checked and my IP is static, but I am using a wireless router as well for other devices. From modem, to wireless router, THEN to my computer. Do I have to make my wirless router static as well?
XxZIOIMIBIExX ®™ 6. Aug. 2013 um 13:02 Uhr 
no you dont, it might be that your bandwidth iis insufficiant, because of the wireless connection, or your bandwidth iitself, on L4D2 it takes a biit more bandwidth than you might thiink to host just the 4 players it supports.

i have no idea why, it must be this branch of the source engine, is my best guess.

but all i can say is, plug in a hardline, AKA Ethernet cable. and see if that works, if it still doesnt work then it might be something to do ether with the steamgroup, or the port the batch file uses, or the ports you opened.

thats all i can thiink of, just make sure that all the ports you opened are the same nd the ones used in the batch files to start your server.

good luck :)
Rick James 7. Aug. 2013 um 19:40 Uhr 
Thanks, I'll be sure to give that a try. One more thing though, before the server finishes loading up it says something along the lines of "SCRIPT PERF WARNING -- 'main' ran long at 6.2103 ms" followed by a bunch of other things like "missing modules, "ERROR: Tried to create bone follwer on invalid bone joint27," and "Verify that skin is valid". Should I be worried about that?
scintillating luminescence 2. Nov. 2013 um 11:36 Uhr 
Here's the guide I used to get my server up and running. http://forums.steampowered.com/forums/showthread.php?t=1381634

I think I had problems until I had my router DMZ the server. So my server was on, say, 192.168.1.7, I had to DMZ that address on my router. I may or may not have had to add a "+ip [WAN IP address]" to my server's launch command line parameters (note that it's + and not - like you might think)

The warnings in the server console are normal. Mostly just annoying. I believe there are some Sourcemod plugins that can block certain messages to the console.
Beiträge 1-5 von 5
< >
Pro Seite: 15 30 50
Geschrieben am: 4. Aug. 2013 um 21:25 Uhr
Beiträge: 5