Mighty Meaty Dec 22, 2013 @ 7:40am
vbsp.exe crashes; require help please
I've got this issue just newly as I copied a map straight unto a new level. I did this because I had a problem with the lighting after applying a custom skybox which I got from http://css.gamebanana.com/textures/3517 . The lighting wouldn't work on textures of the geometry, but props and players would be lit. This propblem only applied for lights with no flicker effects i.e light_environment; light_spot set on normal; light set on normal etc. Anyway, now as I copied the entire map into the new level the compiling crashes. This doesn't happen on any other map, just the one I copied the map into. This is the compile log:
CDynamicFunction: Loading library 'Kernel32.dll' (75290000)
CDynamicFunction: Lookup of 'TryEnterCriticalSection' in 'Kernel32.dll': 76FF254
0
CDynamicFunction: Loading library 'psapi.dll' (74BE0000)
CDynamicFunction: Lookup of 'GetProcessMemoryInfo' in 'psapi.dll': 74BE155C

-------------------------------------------------------------------------------
Running command: cd "C:\Program Files (x86)\Steam 2\steamapps\common\left 4 dead
2\bin"
-------------------------------------------------------------------------------


-------------------------------------------------------------------------------
Running command: "C:\Program Files (x86)\Steam 2\steamapps\common\left 4 dead 2\
bin\vbsp.exe" -game "C:\Program Files (x86)\Steam 2\steamapps\common\left 4 dead
2\left4dead2" "C:\Program Files (x86)\Steam 2\SteamApps\common\Left 4 Dead 2\sd
k_content\mapsrc\spaceship1_2.vmf"
-------------------------------------------------------------------------------

CDynamicFunction: Loading library 'Kernel32.dll' (75290000)
CDynamicFunction: Lookup of 'TryEnterCriticalSection' in 'Kernel32.dll': 76FF254
0
CDynamicFunction: Loading library 'psapi.dll' (74BE0000)
CDynamicFunction: Lookup of 'GetProcessMemoryInfo' in 'psapi.dll': 74BE155C
Valve Software - vbsp.exe (Dec 16 2013)
8 threads
materialPath: C:\Program Files (x86)\Steam 2\steamapps\common\left 4 dead 2\left
4dead2\materials
Loading C:\Program Files (x86)\Steam 2\SteamApps\common\Left 4 Dead 2\sdk_conten
t\mapsrc\spaceship1_2.vmf
fixing up env_cubemap materials on brush sides...
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (16 bytes)
Cannot build Physics2 data
-----------
DataLinker total stream size 0.0 KiB
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10

And then it crashes. Very annoying. Also, the copied map doesn't save into the level as it seems. When I load up the level again in hammer, the map doesn't appear and I need to copy the level back in. I'm lost. If anyone knows anything at all, it'd be greatly appreciated.
Showing 1-1 of 1 comments
< >
Rectus Dec 22, 2013 @ 8:31am 
I have no idea why it crashes, but the lighting not showing up on brushes is a bug in the latest version of the compiler. You can fix it by going to the autoring tools properties, and opting in to the beta.
Showing 1-1 of 1 comments
< >
Per page: 15 30 50
Date Posted: Dec 22, 2013 @ 7:40am
Posts: 1