BananaScrambler Nov 24, 2012 @ 3:13pm
L4D2 freezes after the loading screen.
Just like many people have posted with other discussions, my game will get passed the loading screen but starts repeating noises, gets stuck on the beginning and then eventually crashes.
I've seen discussions but nobody had any answers. I have 16 gigs of RAM available, running Windows 7 64-bit, I have an AMD Radeon HD 6900 series graphic card, an Intel i5-2500K processor at 3.30ghz and DirectX 11 installed, so I don't think my computer is the problem. All my drivers are up to date, but the game still won't work. I've verified the game cache many times, and tried reinstalling it several times. Any help would be greatly appreciated.
Last edited by BananaScrambler; Nov 24, 2012 @ 4:45pm
Showing 1-11 of 11 comments
< >
hunter Nov 24, 2012 @ 4:47pm 
did you try to disable multicore rendering?
BananaScrambler Nov 24, 2012 @ 5:00pm 
I have. Its default setting is set to disabled, but I've tried messing aroung with every available setting and nothing has changed and now have it all set back to default.
Eko21 Nov 25, 2012 @ 6:10am 
I have same problem! When i run the game, after 1 second he close. What i must do?
BananaScrambler Nov 25, 2012 @ 9:22am 
I'm still looking for a solution, when I find one I'll let the community know.
Eko21 Nov 25, 2012 @ 9:26am 
Thank you, now i'm reinstalling left 4 dead 2..
BananaScrambler Nov 25, 2012 @ 9:30am 
I've tried reinstalling it 4 times now, it doesn't help at all. I don't think it's a problem with the install. I had a small moment where it worked for all of 10 seconds when I switched to compatibility mode, but then it did the same thing.
Eko21 Nov 25, 2012 @ 9:34am 
When I try to open l4d2 he tell prperaing to launch the game but he don't run! He close after the launch, now i'm install all service pack for windows 7even..
Glub Nov 26, 2012 @ 5:43am 
Try this: go to Properties>Set Launch Options, type: +mat_hdr_level 0
The game will look a little ugly but worked for me.
BananaScrambler Nov 26, 2012 @ 11:57am 
That didn't work for me, but when I set all the graphics to low & turn off the gore it runs, but like you said it looks like garbage. I've given up though, I'll have to stick to Xbox and miss out on all the mods.
Eko21 Nov 26, 2012 @ 12:02pm 
I've solved the problem..just update for video card driver..
BananaScrambler Nov 27, 2012 @ 10:58pm 
That's not the solution for everyone unfortunately, but it is a step in the right direction.
Showing 1-11 of 11 comments
< >
Per page: 15 30 50
Date Posted: Nov 24, 2012 @ 3:13pm
Posts: 11