Pivo|NL Nov 3, 2012 @ 4:10am
microphone troubles
ok so here is my problem.
ingame i cant adjust my voice transmitting sound.
i does not even find my mic.
in steam i tested my mic it works
i have enabled the steam community ingame so that's not the problem
i have reistalled the game several times and removed all contens and it still wont work

PLS can someone help me

regards Pivo
Showing 1-15 of 21 comments
< >
Drago Nov 4, 2012 @ 1:34pm 
USB or line in?
Pivo|NL Nov 5, 2012 @ 10:05am 
usb
Drago Nov 5, 2012 @ 12:09pm 
Also, what have you set in the options of the game in the microphone section? Is it push-to-talk? Did someone tell you ingame that it doesn't work?

Make sure that your USB headset is set as the default playback device for Windows, as well as disabling any other possible playback devices.
Last edited by Drago; Nov 5, 2012 @ 12:13pm
Pivo|NL Nov 5, 2012 @ 12:38pm 
i have push to talk it does not work ingame i only have headset on this pc so it is always been on default
it have worked before..

Drago Nov 5, 2012 @ 1:44pm 
Ah, I'm not sure what the problem could be then. Sorry!
dbostick Jan 10, 2013 @ 3:21pm 
I can't get my Logitech USB headset to work in this game at all.

It is set up in Steam and I can chat in every other game except for this.
Pivo|NL Jan 11, 2013 @ 9:12am 
yeay so i had the same problem u should adjust something in console i dont know anymore how but ill try to find it and tell u
tom Apr 15, 2013 @ 12:20am 
for mac - similar, possibly the same, problem. In line headset w' microphone, works perfectly outside game (and in Steam), but goes extremely quiet or disappears when in game. Audio settings have 'microphone sensitivity' apparently locked at zero (I think that's what the red bar means). Microphone test in game shows it's extremely quiet. Outside of game (and in other games) works fine. V v frustrating as bought it for multiplayer, but cannot use in-game chat.
Last edited by tom; Apr 15, 2013 @ 12:20am
Pivo|NL Apr 15, 2013 @ 8:09am 
yeay i have been looking for the command in colsole but i cant find it
i know u have to change it somehow in console make from a 1 a 0 or something
tom Apr 15, 2013 @ 10:51am 
ok, thanks Pivo|NL - will have a look for it.
tom Apr 15, 2013 @ 10:54am 
pivo - when you say 'in console' do you mean in the OS sound settings, or somewhere else? (sorry if this is a stupid question)
tom Apr 15, 2013 @ 1:32pm 
likely commands:

voice_avggain 0 None
voice_clientdebug 0 None
voice_dsound 0 None
voice_enable 1 None
voice_fadeouttime 0 None
voice_forcemicrecord 1 None
voice_inputfromfile 0 Get voice input from "voice_input.wav" rather than from the microphone.
voice_loopback 0 None
voice_maxgain 10 None
voice_modenable 1 Enable/disable voice in this mod.
voice_overdrive 2 None
voice_overdrivefadetime 0 None
voice_profile 0 None
voice_recordtofile 0 Record mic data and decompressed voice data into "voice_micdata.wav" and "voice_decompressed.wav".
voice_scale 1 None
voice_serverdebug 0 None
voice_showchannels 0 None
voice_showincoming 0 None
voice_steal 2 None
Pivo|NL Apr 16, 2013 @ 2:51am 
the commands above does remembet me of the commands i use and what i mean whit console u will get it by pressing ~ <<< that sign on keybord
it is possible u have to press a first in console atleas i have that problem :D
tom Apr 19, 2013 @ 1:36pm 
thanks pivo
AnimeFunTV Jul 7, 2013 @ 11:51pm 
I'm also having the same issue, using OSX Settings, I can set my usb headset to default on both output and input, I can see with the audio meter in input that the microphone is easily picking up my voice without having to talk loudly.

Next I go into Steam and check the properties and voice tab and I can test the microphone and it too easily picks up my voice very easily.

But once I start L4D2, I go into the settings and audio, and I do a microphone test and its so low, I can hardly hear myself. I have the settings for the microphone on high in the game and I would have to almost yell for the microphone to pick me up on the meter bar.

BUT, if I command+tab and go back to OSX Audio settings the game has set the microphone volume to its lowest setting, If I manually set it to max I can hear myself, but as soon as I command+tab back into the game the microphone volume goes back to minium.

The game is somehow overriding the OSX Audio Settings and setting the Volume Input to its lowest and I even though I can command-tab back and max it out, once I go back into the game it overrides it again
Showing 1-15 of 21 comments
< >
Per page: 15 30 50
Date Posted: Nov 3, 2012 @ 4:10am
Posts: 21