Joruzhia Oct 29, 2012 @ 9:18am
engine error could not load library client
So I havent played this game for while so today i tried to play it.... aaaand then happened this ??? engine error could not load library client it comes right after intro movie and game crashes to desktop. I have tried to re-install steam, re-install that game, verifying game data, etc. but nothing seems to help. So now im out of ideas so IF there is someone maybe YOU who knows how to get game working then please put some text. Thanks anyway
Showing 1-13 of 13 comments
< >
Tunaboat Oct 29, 2012 @ 10:42am 
I hate to be one of the people to say, "HAY I HAF THIS PROBLEM 2 AND KENT FIGYOR OUT ON MY OWN" But, yeah, Same problem here, verified cache, reinstalled steam, tried reacquiring client dlls, tried skipping opening cinematics, tried, defragging, then verifying, fresh installed steam, uninstalled reinstalled l4d2 at least 3 times, took a few of the library files from l4d2 out,see if they were corrupted on verifying, turns out, i still get the same problem, I have over 300 hours in the game, so it's not a reoccurring problem, Is there a registry string I have to fix? Sorry I couldn't help you rambo, but this is getting ridiculous, I'm just as mad as you are right now. EDIT: Tried removing all registry files, not finding an app with l4d2's steam appid, found it pretty useless, still trying things out, if I get anything done, I'll post it here.
Last edited by Tunaboat; Oct 29, 2012 @ 11:02am
Joruzhia Oct 29, 2012 @ 11:21am 
YEA WE NEED SOME SUPPORT AT HEREEE please.
TheBunnyKicker Oct 30, 2012 @ 3:30am 
I hate that i have no help to offer on this but i'm having the exact same problem.

I've done everything that you guys have, and i have tried repairing the files through command prompt. Nothing seems to make a difference. I have no add ons or mods; i don't even have a spray paint. I've never messed with my steam or L4D2 files..

I started having this problem right after the latest update to steam.. whenever i restarted steam after the update I was no longer able to play..

It's frustrating because my friends keep inviting me so obviously this isn't a widespread issue and i have no idea why it is happening to me. Good to see I am not alone though.

I tried everything in this link: https://support.steampowered.com/kb_article.php?ref=9626-UOAC-4950
Tunaboat Oct 30, 2012 @ 9:44am 
I've done a bit of research, and It seems to change the error, every time I poke around with the client.dll file, in "C:\Program Files (x86)\Steam\steamapps\common\left 4 dead 2\left4dead2\bin" The error message changes, when its removed, or swapped for another file, But, if attempted to edit this dll file, to see if anything is screwy with it, It says access is denied, with every type of program I use, Even though I'm the clear admin of this computer, That's the only thing That I seemed to notice so far, but I'll keep looking. :U Keep me updated if any light is shed on this.
Last edited by Tunaboat; Oct 30, 2012 @ 9:45am
Joruzhia Oct 30, 2012 @ 10:31am 
Yeah Thanks man to trying to find some help to this problem
joaodaniel Oct 30, 2012 @ 11:21am 
I got this problem since i bought this on January i guess.For me this error starts with that new map update.
Same problem,hope they fix
Master of Cupcake Oct 31, 2012 @ 5:57am 
Having the same problem too! Why can't they let us know on what to do?
Bobo Oct 31, 2012 @ 7:46am 
tldr; same error, tried everything, friends got it over free weekend and theirs works, let down, dissapoint

Exactly same problem, reinstalled game, reinstalled steam, verified cache. Thought it might be some outdated DLC/UGC but I deleted all the custom maps and mods from my files, nothing seems to work. It's kind of a let down when you, like me, spent money on this game. I bought it a while ago and my friends got it over the free weekend. All theirs work fine, just mine that is playing up. Anyone know when we might get an answer?
holycrapnoname87 Nov 1, 2012 @ 2:42pm 
Having this same problem too, buddy told me to buy it so we could play and after 3 downloads and a bunch of other stuff no luck. Really wish Valve would help us out...
Tunaboat Nov 1, 2012 @ 10:44pm 
GOT IT, This worked for me at least, If you previously had L4D 1 installed, and removed it, I recommend downloading at least the first 10% of it, models get shared between the games, and it gives a nasty error otherwise, This worked for me, Tell me if it worked for everyone else.
Joruzhia Nov 2, 2012 @ 9:30am 
Didn't work sorry dude
Joruzhia Nov 2, 2012 @ 9:53am 
OK so they patched L4D2 today and it works now perfectly... so thanks
Tunaboat Nov 2, 2012 @ 3:40pm 
Kay. sweet. XD
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Oct 29, 2012 @ 9:18am
Posts: 13