Paddy Oct 26, 2012 @ 10:36am
Just bought L4D2 : Doesn't boot
Hello there, I need your help :(

When I launch the game, the screen goes black for like 2s then it goes back to desktop, and the game just doesn't work.

I've rebooted, re-installed, verified the game cache, ...

I just can't launch the game. Anyone have an idea? Cheers



pc specs :
windows7 / 64bit
MSI Big Bang Marshall MB
Nvidia GTX 580 (updated)
8Go RAM - 120G SSD
Showing 1-15 of 53 comments
< >
Paddy Oct 26, 2012 @ 7:35pm 
bump
UnsounderGnome Oct 26, 2012 @ 8:37pm 
Maybe try running as administrator?
Castaa Oct 26, 2012 @ 8:57pm 
Same issue here. Windows 8 maybe?
Paddy Oct 27, 2012 @ 12:36pm 
Im on windows 7. Tried running as administrator, and in safe mode 800*600, nothing works.

I sent a support ticket to valve, no answer yet. . . .
Paddy Oct 27, 2012 @ 5:53pm 
bump
dosh11 Oct 27, 2012 @ 6:47pm 
it coud be youer fire wall our anti virus messing it up it happens some times
Paddy Oct 28, 2012 @ 7:32am 
disabled both, still something going wrong
De De Oct 28, 2012 @ 7:35am 
I'm quite sure your problem is window firewall.
Paddy Oct 28, 2012 @ 8:30am 
I've taken it off. As a matter of fact I have never activated it. Ever.

I think this is more of a graphical problem, not internet-wise
Wargraven Oct 28, 2012 @ 8:31am 
I had a similar problem. I fixed by right clicking on L4D2, selecting properties, click set launch options, typed "-novid" without the quotes. I disabled the intro vid and I can play!
Paddy Oct 28, 2012 @ 8:31am 
By the Way I play on a TV screen, that can handle lots of resolutions, and when I launch L4D2 it automatically goes into 1024*768, but I still can't see anything, it's just a black screen.
Paddy Oct 28, 2012 @ 8:31am 
I'll try that AFK FOOD, thanks for the comment ! :)
Paddy Oct 28, 2012 @ 8:31am 
I'm currently REdownloading it for the 5th time.
Paddy Oct 28, 2012 @ 8:59am 
I put -novid but still doesnt work.

Tried -windowed, I see the game open, it stays there for 2 seconds then closes.

WTF Valve ?!

I put a ticket 2 days ago, they still haven't replied... :(
Showing 1-15 of 53 comments
< >
Per page: 15 30 50
Date Posted: Oct 26, 2012 @ 10:36am
Posts: 53