Brandeeno Oct 5, 2013 @ 9:13am
Question! (Console Commands)
is it possible to edit the default console commands such as:
survivor_friendly_fire_factor_normal 0
survivor_friendly_fire_factor_hard 0
survivor_friendly_fire_factor_expert 0

because mine are set to this by default:
survivor_friendly_fire_factor_normal 0.1
survivor_friendly_fire_factor_hard 1.3
survivor_friendly_fire_factor_expert 3.4

is there a way to permanantly change it back to 0 for all because they used to be that way and now they set themselves to that for some reason.
Showing 1-13 of 13 comments
< >
Shao Oct 5, 2013 @ 9:29am 
Edit your server.cfg and add those. Not sure if it applies on local, probably is. You could simply make a cfg file in the cfg folder and exec it with console while playing.
Brandeeno Oct 5, 2013 @ 9:30am 
ok, thanks! I'll try that.
Brandeeno Oct 5, 2013 @ 9:44am 
Originally posted by Gris Echoes:
Edit your server.cfg and add those. Not sure if it applies on local, probably is. You could simply make a cfg file in the cfg folder and exec it with console while playing.
ok... I made a file to exec them but it still says i need to enable sv_cheats but i try that and it doesn't let me... and i looked everywhere for that server.cfg file and there's no such thing... so i created my own to exec it in-game and as i said before it didn't work. I don't understand why my default setting for friendly fire are set on, because this started happening yesterday but before that i would play on normal all the time and there was no friendly fire whatsoever and now for some reason there is. there's got be a way!
Shao Oct 5, 2013 @ 9:48am 
Originally posted by Brandeeno:
ok... I made a file to exec them but it still says i need to enable sv_cheats but i try that and it doesn't let me... and i looked everywhere for that server.cfg file and there's no such thing... so i created my own to exec it in-game and as i said before it didn't work. I don't understand why my default setting for friendly fire are set on, because this started happening yesterday but before that i would play on normal all the time and there was no friendly fire whatsoever and now for some reason there is. there's got be a way!
Add sv_cheats 1 at the top of the commands, input commands, then turn it off with sv_cheats 0 at the right bottom. It should be enable for a few secs for the commands to change then turn off, i can't be convinced the console will act like if cheats was never turned on however.
Last edited by Shao; Oct 5, 2013 @ 9:48am
Brandeeno Oct 5, 2013 @ 9:56am 
Originally posted by Gris Echoes:
Originally posted by Brandeeno:
ok... I made a file to exec them but it still says i need to enable sv_cheats but i try that and it doesn't let me... and i looked everywhere for that server.cfg file and there's no such thing... so i created my own to exec it in-game and as i said before it didn't work. I don't understand why my default setting for friendly fire are set on, because this started happening yesterday but before that i would play on normal all the time and there was no friendly fire whatsoever and now for some reason there is. there's got be a way!
Add sv_cheats 1 at the top of the commands, input commands, then turn it off with sv_cheats 0 at the right bottom. It should be enable for a few secs for the commands to change then turn off, i can't be convinced the console will act like if cheats was never turned on however.

nope, no luck. it says i have to execute it by starting a game from console then exec it in-game. all i want to do it start singleplayer game with the default settings set to survivor_friendly_fire_factor_normal 0
survivor_friendly_fire_factor_hard 0
survivor_friendly_fire_factor_expert 0
and play normally without having to remember every maps dvar name.
Shao Oct 5, 2013 @ 10:00am 
You can't do that on single player, start the game via console. "map c1m1_hotel coop" for example, nobody will join you if you don't have the ports open. If you can't remember then, look up the suggestion the console makes, you'll find them soon enough.
Last edited by Shao; Oct 5, 2013 @ 10:01am
Brandeeno Oct 5, 2013 @ 10:02am 
yea but i don't understand why it would just change the settings on its own. there was no friendly fire bfore but now all of a sudden there is? is there a way to revert changes?
Shao Oct 5, 2013 @ 10:06am 
Single Player is a static mode and the settings always put themselves back to default unless you load them up with a cfg file, the way i do with my server of course as everybody else.
Brandeeno Oct 5, 2013 @ 10:09am 
the thing is, somewhere along the line something happenned and the default settings were changed and friendly fire was turned on in the default settings. either that or my l4d2 isn't disabling some add-ons properly and one of them changed the default settings.
Shao Oct 5, 2013 @ 10:10am 
Everything that's console wise will always reset back to default upon closure of the game.
Last edited by Shao; Oct 5, 2013 @ 10:10am
Brandeeno Oct 5, 2013 @ 10:12am 
Originally posted by Gris Echoes:
Originally posted by Brandeeno:
the thing is, somewhere along the line something happenned and the default settings were changed and friendly fire was turned on in the default settings. either that or my l4d2 isn't disabling some add-ons properly and one of them changed the default settings.
Everything that's console wise will always reset back to default upon closure of the game.

for some reason it's not reseting everything or the resent crash that i had may have messed with a few things but that crash happenned after my game was affected and after reinstalling l4d2 so i don't know what it is. Do you know of anyway to change the default setting manually?
Shao Oct 5, 2013 @ 10:20am 
If you were to host from a dedicated, that'd would be more simple, but since you're trying over local hosting. It's a bit different, if the server.cfg didn't work. I have no idea.

// Server Control

hostname "Insert Host Name"

rcon_password "Insert Password"

sv_search_key "Insert Search Key"
sv_forcepreload "1"
sv_allow_lobby_connect_only "0"
sv_consistency "1"
sv_voiceenable "1"
sv_region "0,1"
sv_logbans "1"
sv_lan "0"
sv_pure "1"
sv_cheats "0"
sv_log_onefile "0"
sv_gametypes "coop,realism,survival,versus"
sv_steamgroup "Insert Group ID"
sv_rcon_minfailures "1"
sv_rcon_maxfailures "1"
sv_rcon_banpenalty "0"

mp_disable_autokick "1"

motd_enable "1"

This is how it should look usually when you have a server.cfg. If you were to add the commands you want i'd do a sub section like this under the followed motd.

//Friendly Fire Control

survivor_friendly_fire_factor_normal 0
survivor_friendly_fire_factor_hard 0
survivor_friendly_fire_factor_expert 0

If you tried with and without sv_cheats 1, then it must be really necessary for you to install sourcemod. However, it's very instable when hosting local with it.
Rectus Oct 6, 2013 @ 2:23am 
Another option would be to create a mutation with the appropriate convars set. Just add something like this to a text file in common\left 4 dead 2\left4dead2\modes:
"disableff"
{
"base" "coop"
"maxplayers" "1"

"Author" ""

"DisplayTitle" "Singleplayer without friendly fire"

convar
{
survivor_friendly_fire_factor_normal 0
survivor_friendly_fire_factor_hard 0
survivor_friendly_fire_factor_expert 0
}
}

Then you should be able to start it through the mutation menu without having to turn on cheats.

Or through the console with: map mapname disableff
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Oct 5, 2013 @ 9:13am
Posts: 13