imnrk Sep 28, 2013 @ 8:40pm
Missing Texures or Something?
So I installed L4D2 yesterday, and the water and sometines the zombies are both messed up. The water keeps flashing different solid colors and sometimes a zombie will be yellow or green. I tried re-installing L4D2 today, and i had no programs running. I also have DX11, so that shouldn't be a problem. I'd appreciate help, thanks for reading!
Showing 1-10 of 10 comments
< >
ÐÜÐĘŞåÜ©Ę™ Sep 28, 2013 @ 9:43pm 
Having dx 11 is part of your operating system,it sounds like your l4d2 is not creating a certain shader format.open the developer console and see if you have red lettered writnig stating something like"failed to creat shader".If you do then what this means is your gfx cards shader capability is below minumum requirements.I know because this exact same thing happened to me when my gfx card was fast enough and it had enough memory,but it didnt have shader 2.0B(i think it had A not B).Zombies shirts would be bright in color(like hot pink,or yellow or green)flashing just unnatural colors.Especialy with flashlight on.Water was very wierd too flickering from bright white to drak grey depending on angle of view.Needless to say an updated gfx card fixed it.What is your card anyways?Sorry for the long reply but that was the same exact symtoms that I encountered.
Shao Sep 29, 2013 @ 1:39am 
Originally posted by ÐÜÐĘŞåÜ©Ę™:
Zombies shirts would be bright in color(like hot pink,or yellow or green)flashing just unnatural colors.
For those crazy rainbow zombies, it's about the l4d2 models getting remplaced by the l4d1 one's. It randomly happens sometimes, never understood why, but this results in strange colors because of the uncapacity of being heavily wounded on the first models. It's some .txt campaign failure when loading.
Captain Caboose Sep 29, 2013 @ 1:43am 
Originally posted by Gris:
For those crazy rainbow zombies, it's about the l4d2 models getting remplaced by the l4d1 one's. It randomly happens sometimes, never understood why, but this results in strange colors because of the uncapacity of being heavily wounded on the first models. It's some .txt campaign failure when loading.
I believe that's because L4D1's Infected models aren't precached. Either way, it has something to do with Left 4 Dead's Common Infected models.
This is common across all games though, so it's not a specific problem with the OP's installation.
Shao Sep 29, 2013 @ 1:51am 
Originally posted by Those Dirty Blues:
I believe that's because L4D1's Infected models aren't precached. Either way, it has something to do with Left 4 Dead's Common Infected models.
That could be it, after all. You can notice how the L4D1 patient in no mercy is not even making blood when you blow his head off, neither losing anything else. This is probably due to lazyness. Knowing how valve ports. Say, L4D2 is the same thing as L4D1, just a ton of updates made it to look like another game, hence the common's model still existing.
Last edited by Shao; Sep 29, 2013 @ 1:52am
imnrk Sep 29, 2013 @ 8:10am 
So I tried updating my graphics card, but windows said that is was already up to date. This is weird, because i kept on getting the errors in my console from the water, and the symtoms still remained. But I know this isnt normal since I know alot of other people with both these games, and the both work fine. And my L4D1 has no problems.
ÐÜÐĘŞåÜ©Ę™ Sep 29, 2013 @ 9:44am 
What is your card model/specs?Are you getting the specific error in game console(failed to creat shader) or (failed to creat sky box)?
imnrk Sep 29, 2013 @ 10:45am 
Radeon X300/X550/X1050 0times5B60. The errors i get are "failed to create shader."
imnrk Sep 29, 2013 @ 10:48am 
and "trying to set a pixel shader that failed loading"
ÐÜÐĘŞåÜ©Ę™ Sep 29, 2013 @ 12:10pm 
Im afraid that card doesnt support l4d2 graphics(the shader portion)you will need at least an x800 card(shader 2.0B at least)What you are currently using is unsupported :( same problem I had.Im currently using a HD Radeon 4650 with 1GB and Im able to max the game,but any card x800 or higher should get rid of those errors.
imnrk Sep 29, 2013 @ 1:08pm 
ok, thanks. I'll just replace it sometime when I have more money.
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Sep 28, 2013 @ 8:40pm
Posts: 10