Say_It_With_Bullets™ Sep 21, 2013 @ 10:35am
Ubuntu 12.04 L4D2 crashes
Is there a guide for this? I have not found a solution.

On Ubuntu 12.04, Left 4 Dead 2 (Beta) ("out of beta" beta, the one that sees players from other OS), I get:
a) L4D2 crashes before I finish connecting to a game;
b) I connect to a game but it crashes before I can click to join as a player
c) I can join a game (once in ten tries) but I need to change RAW MOUSE INPUT either enable or disable, depending on the previous setting.

As stated, I can only connect once in ten tries at best. There are no logs or error messages that I can find; no request to send an error report as usually encounter with ubuntu errors.

I tried this with 32 bit x86 and 64 bit amd64

Is WINE a better solution? There are many internet pages on WINE, about half say it works fine and half says it does not work at all, or somewhere in between. Can anybody point to the instructions they used that actually worked for them?
Showing 1-6 of 6 comments
< >
sophia Sep 21, 2013 @ 10:43am 
I have L4D2 on Ubuntu and I haven't had any problems with crashes.
Say_It_With_Bullets™ Sep 21, 2013 @ 11:09am 
What Ubuntu version, what hardware?

I have a core2 duo E6750 cpu, perhaps thats too old?

I notice that things may improve when go to Video -> advaced -> Multicore Rendering -> DISABLED
Althought it ran once, it crashed the second time. I recall this from a prior install. I notice this must set each time the game is started, it does not retain the setting between sessions.

I have NT8800GTX GeForce video cad, could this be too old?
sophia Sep 21, 2013 @ 12:48pm 
Originally posted by Say_It_With_Bullets™:
What Ubuntu version, what hardware?

I have a core2 duo E6750 cpu, perhaps thats too old?

I notice that things may improve when go to Video -> advaced -> Multicore Rendering -> DISABLED
Althought it ran once, it crashed the second time. I recall this from a prior install. I notice this must set each time the game is started, it does not retain the setting between sessions.

I have NT8800GTX GeForce video cad, could this be too old?

You know, it might just be your hardware. Despite Valve's boner for Linux most of the games on here don't run optimally. Do you have any trouble running other Linux games? You might want to try Wine to see if it works, at least that way you could use a mic in game.
Say_It_With_Bullets™ Sep 21, 2013 @ 1:45pm 
I didn't have issues with Portal on linux. The same machine ran all my steam games just fine under XP, so I figured the hardware itself should be sufficient.

I managed to install wine 1.4, and L4D2 is install now; I'll try to post a result.
Say_It_With_Bullets™ Sep 21, 2013 @ 2:42pm 
Wine installed, L4D2 installed. But sound is screwed up. It seems to play at double speed, and is very scratchy. Doing the test audio in configure wine just give a static sound regardless of with hardware option I select.

Any links to solutions?
Say_It_With_Bullets™ Sep 21, 2013 @ 3:17pm 
OK, it turns out that we must change WINE windows version from WXP to Win8, set audio default, and reboot. This fixes the sound. So far it seems laggy, Dark Carnival was comparable to Cold Stream under WXP. But at least it works a bit.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Sep 21, 2013 @ 10:35am
Posts: 6