Jaller Sep 9, 2013 @ 10:24am
Left 4 Dead 2 crashes when joining a game server.
Hi, i'm having an issue here. Whenever i join or create a server L4D2 will crash when it's amlost halfway done. Might be my addons causing it and ive tried disabling most of the addons, any help?

Info about my computer: Intel (R) Core(TM) i5 CPU 750 @ 2.67GHz
32 - bit operating system.
Last edited by Jaller; Sep 10, 2013 @ 8:24am
Showing 1-15 of 15 comments
< >
Shitstorm|Xmas Day Sep 9, 2013 @ 12:16pm 
Sollution : I had this problem before and I found out how to do it! Firstly, is there an error message after you crash and secondly do you happen to have any mods that are in the not working bit when you go to workshop
Shao Sep 9, 2013 @ 2:27pm 
Disabling doesn't remove their entity. You'll have to go ahead and remove them entirely along with the subscriptions. To do that, you go to \SteamApps\common\left 4 dead 2\left4dead2\addons for manual addons, and workshop ones with \SteamApps\common\left 4 dead 2\left4dead2\addons\workshop
Jaller Sep 10, 2013 @ 7:54am 
Originally posted by Henryhunter12345:
Sollution : I had this problem before and I found out how to do it! Firstly, is there an error message after you crash and secondly do you happen to have any mods that are in the not working bit when you go to workshop
Sometimes it does say "Failed after 10 retries" instead of crashing right to the destop. But most of the times it crashes right into the destop when loading a game. Sometimes the game crashes about 1-2 times when downloading all of the addons, but have no idea what addon can cause this since this.
Last edited by Jaller; Sep 10, 2013 @ 8:00am
Jaller Sep 10, 2013 @ 8:21am 
Originally posted by Resh ♫:
Disabling doesn't remove their entity. You'll have to go ahead and remove them entirely along with the subscriptions. To do that, you go to \SteamApps\common\left 4 dead 2\left4dead2\addons for manual addons, and workshop ones with \SteamApps\common\left 4 dead 2\left4dead2\addons\workshop
Tried doing that, same result happens again.
Hawk Sep 10, 2013 @ 1:24pm 
I think I'm having same problem. Crash does not occur (so far) with Official Ded. servers. Game crashes to desktop on Best available, group servers, etc. This happens when I create the lobby; it hasn't happened when I join someone else's game.

The crash always occurs at the same time in the load. The cut scene at the beginning plays okay. The game crashes to the desktop between 5 to 10 seconds after I take over the avatar.

If I try to restart too soon I get the "app is still running" error.

If I keep trying (up to 4 or 5 times so far) sometimes I'll get in.

BTW, perhaps unrelated, a good way I've found to isolate an addon seems to be: rename the addons folder to something.bak (or whatever), then create a new addons folder and place only the addon you want to play there. The rest can be regained by simply reversing the process.
Last edited by Hawk; Sep 10, 2013 @ 1:28pm
Jaller Sep 11, 2013 @ 10:18am 
Originally posted by Hawk:
I think I'm having same problem. Crash does not occur (so far) with Official Ded. servers. Game crashes to desktop on Best available, group servers, etc. This happens when I create the lobby; it hasn't happened when I join someone else's game.

The crash always occurs at the same time in the load. The cut scene at the beginning plays okay. The game crashes to the desktop between 5 to 10 seconds after I take over the avatar.

If I try to restart too soon I get the "app is still running" error.

If I keep trying (up to 4 or 5 times so far) sometimes I'll get in.

BTW, perhaps unrelated, a good way I've found to isolate an addon seems to be: rename the addons folder to something.bak (or whatever), then create a new addons folder and place only the addon you want to play there. The rest can be regained by simply reversing the process.
Mind if i add you? mayby we can have a talk so we can fix the solution better.
Hawk Sep 11, 2013 @ 12:48pm 
Oops, Jailer, I didn't recognize you before I read this. I'll see if I can add ya. Ahh, quite a few Jailers! Please add me again? TIA
Last edited by Hawk; Sep 11, 2013 @ 12:51pm
Jaller Sep 12, 2013 @ 7:47am 
Originally posted by Hawk:
Oops, Jailer, I didn't recognize you before I read this. I'll see if I can add ya. Ahh, quite a few Jailers! Please add me again? TIA
No worries, just rebooted my computer to 64-bit. The game better bloody work now.

EDIT: It works now :D
Last edited by Jaller; Sep 14, 2013 @ 5:25am
Jaller Nov 9, 2013 @ 6:59am 
Originally posted by Hawk:
Oops, Jailer, I didn't recognize you before I read this. I'll see if I can add ya. Ahh, quite a few Jailers! Please add me again? TIA
Hi, long time no see and mayby you've fixed your L4D2 by now. I added you so we can mayby play L4D2 together some time, Unless you have something against?
The knight Nov 9, 2013 @ 8:59am 
had this aswell i just turend off all mods and went into the game it worked came out and turend them back on and it still worked sort of a manual re-set
Jaller Nov 9, 2013 @ 9:10am 
Originally posted by JET OF EASY:
had this aswell i just turend off all mods and went into the game it worked came out and turend them back on and it still worked sort of a manual re-set
My game is already fixed, but thanks for sharing.
Jaller Nov 10, 2013 @ 1:08am 
Originally posted by Hawk:
Oops, Jailer, I didn't recognize you before I read this. I'll see if I can add ya. Ahh, quite a few Jailers! Please add me again? TIA
Hey hawk, my friend list is being ♥♥♥♥♥♥♥♥ and keep saying that i need to delete friends after deleting more than 33 friends, so i'm going to have to readd you. I'll add you a bit later after ive fixed the friend list thing.
Jaller Nov 10, 2013 @ 1:09am 
Originally posted by Hawk:
Oops, Jailer, I didn't recognize you before I read this. I'll see if I can add ya. Ahh, quite a few Jailers! Please add me again? TIA
Sent you a request, plz accept it D:
S̸k̨ul̕linator̀ Apr 23 @ 9:44pm 
I have the same problem, but after it crashes it shows nothing.
I can't deal with it. ;3;
Jaller Apr 24 @ 8:00am 
Originally posted by Akana:
I have the same problem, but after it crashes it shows nothing.
I can't deal with it. ;3;
Try contacting steam support, i got it fixed by rebooting the computer.
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Sep 9, 2013 @ 10:24am
Posts: 15