South Jersey Sam Sep 7, 2013 @ 6:42pm
Mic Issues
So far, L4D2 won't let me use my mic. It's a Blue Snowball, and it does work, but it won't work on L4D2.
Showing 1-4 of 4 comments
< >
Cipher141 Sep 7, 2013 @ 6:52pm 
Check in the game options if the mic is enable, or check for drivers for your mic
South Jersey Sam Sep 7, 2013 @ 7:02pm 
it wont even show the options for the mic.
HarlemSquirrel Sep 7, 2013 @ 10:55pm 
First of all, Blue Snowball is an awesome mic! It's best used for recording live instruments, vocalists, or podcasting. I would't recommend it for L4D2. The best mic for games like this would be part of a headset, like one of these <http://gaming.logitech.com/en-us/gaming-headsets> or these <http://www.newegg.com/Headsets-Accessories/SubCategory/ID-707>. Second, are you running Linux? If so, L4D2 on Linux does not yet have voice chat working. I hope this helps! :)
taithope Sep 8, 2013 @ 12:20am 
on your computer hardware and sound make the settings to detect the mic i hope this useful


Using Your PS3 wireless headset. Left for Dead or 2 settings
1. Plugin your PS3 wireless headset and turn it on”.
2. “Click” start.
3. “C” Control Panel.
4. “C” Hardware and Sound.
5. “C” Manage audio devices.
6. Automatically shows Speakers 2- Wireless Stereo Headset.
7. Highlight Speakers 2- Wireless Stereo Headset.
You can “C” Configure to test sound.
8. “C” Recording.
9. “C” Microphone Speakers 2- Wireless Stereo Headset.
10. “C” Properties on the bottom.
11. “C” Listen.
12. “C” Listen to this device.
13. Playback through this device select
Speakers 2- Wireless Stereo Headset.
14. “C” Apply, then “C” ok.
Your PS3 Headset should be operational.
15. Left for dead settings “C” Options.
16. “C” Audio.
17. “C” Test microphone, you might get to hear a buzzing sound.
18. Highlight Speaker configuration, select 7.1 speakers. Then ready to play.
This work for me.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Sep 7, 2013 @ 6:42pm
Posts: 4