DoomTrain Aug 2, 2013 @ 8:52pm
L4D2 became very choppy after one of the udpates
My hardware hasn't changed at all in a year, but the game just became SO DAMN CHOPPY. It used to be butter smooth last time I played it. I think it was somewhere in between 200-300 FPS. Now it plays like it's struggling to maintain 20 FPS.

Windows 7 (all updates)
i5 3570K @ 4.2Ghz
MSI 6970 Lightning 2GB VRAM (13.4)
ASRock Z77 Extreme4-M
Mushkin Enhanced Chronos SataIII 240GB SSD
Showing 1-7 of 7 comments
< >
Overdose Aug 2, 2013 @ 8:53pm 
The game's completely F'd. Valve needs to un♥♥♥♥ themselves right quick & fix their game
mr.NOPE. Aug 2, 2013 @ 9:02pm 
so...
THEBIGREDMACHINE Aug 3, 2013 @ 12:30am 
I don't know if your case is the same as mine but since the last update I got, my video settings always reset to a higher setting that what my computer can handle after I close the game and restart.If I play with those settings, the game runs like crap. I always have to go in and reset my video settings everytime I play now. I use native resolution and I set all the advanced settings to medium and the game runs fine.
~HaZe( ͡° ͜ʖ ͡°) Aug 3, 2013 @ 3:54am 
Since the last update my animated sprays don't work -.-. My friend has the same problem and we don't know how we can fix the problem. Has anyone an idea ?
acommoncreeper Aug 3, 2013 @ 9:39am 
Past couple updates have broken lots of things. The game is more unstable then an empire state building made out of straw.
( o Y o ) Aug 3, 2013 @ 9:40am 
Originally posted by Gman:
I don't know if your case is the same as mine but since the last update I got, my video settings always reset to a higher setting that what my computer can handle after I close the game and restart.If I play with those settings, the game runs like crap. I always have to go in and reset my video settings everytime I play now. I use native resolution and I set all the advanced settings to medium and the game runs fine.


^^ most ppl forget to check this with each major update.
DoomTrain Aug 3, 2013 @ 4:47pm 
Before this issue my 6970 was able to handle everything maxed out already though, same thig maybe closer to the 200 FPS mark instead of 300. None of the Valve games are that hard to run. I guess I'll just play around in CCC, maybe I messed up something when I was trying to figure out how to get the Max Payne 1 and 2 games to work. Thanks for the comments guys.

I did notice that alot of weird bugs started to happen when I came back, more often than previous updates. Maybe it was all the custom content clashing with the updates. I used to have a ton of custom maps from the l4dmaps site, and I only had a few skins, at the worst though, some of them didn't have animations (Nude Zoey, lol, stuck in the "jesus pose"). But that was all.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Aug 2, 2013 @ 8:52pm
Posts: 7