CNBFTBGB Jul 10, 2013 @ 7:50pm
Can't get L4D2 to Start from Steam Client
Do you think this may be due to the fact that I installed the game in a custom directory?


As soon as I click L4D2 I get an (unknown error) and it won't launch. I decided to go straight to where I installed the game and run the exe from the common files and it runs! However I get this message: [IMG]http://i.imgur.com/aSSNVYj.jpg?1[/img]

I've checked the launch options and do not see -insecure there...is that because I am running the game outside of the steam client (with steam still running)? I'm running out of ideas here and at wits end!!!
Showing 1-5 of 5 comments
< >
R3d_D@wn Jul 10, 2013 @ 8:07pm 
i had the samw insecure error bcoz i had copyed my steamapps folder in drive E and my l4d2 game was installed in drive D u chk by going in properties > local files and see on the top disk usage and which drive is it in i changed it and the game works (mean's i had to change the steampps folder location hope this helps
CNBFTBGB Jul 10, 2013 @ 9:34pm 
Thanks for your input! Unfortunately it didn't work. I even unistalled/reinstalled to no avail. Still getting an (unknown error) message when trying to launch from steam. I even installed it in the default drive/directory.

Valve..we're going to have beef soon if I wasted my money!

edit: figured it out. If you're on Windows 8 and having this problem, it could be due to not running steam as an administrator and no turning UAC all the way down does not make every program run as admin like it did in W7. Exit steam, then right click and run steam as admin and it should resolve the problem.
Last edited by CNBFTBGB; Jul 11, 2013 @ 8:45am
CareTaker Aug 20, 2013 @ 7:27pm 
I had this same problem with a fresh install of Steam and L4D2 on a secondary internal hard drive. I found my problem was a permissions issue with one or more folder in my %userprofile% directory (typically c:\users\[username]).

In my case I had to take ownership of ALL the files contained in my user profile directory, then reset all the permissions to inherit from parent.

To take ownership, go to Start -> Run -> "%userprofile%\appdata"
Then for each of the folders, follow these directions (be sure to select the "replace owner on subcontainers" option:
http://technet.microsoft.com/en-us/library/cc753659.aspx

Then I had to reset the permissions of all the child objects. I did this by doing the following for each folder:
Right click -> Properties -> Security tab -> Advanced -> Change Permissions... -> check "Replace all child object permissions..." -> OK

Hopefully this will help!
Kevkas May 13 @ 11:45am 
I had the same problem. Running Steam as Administrator solved it. :)
CareTaker May 13 @ 6:58pm 
Fair enough, but I would never consider that a solution, just a temporary workaround.
Showing 1-5 of 5 comments
< >
Per page: 15 30 50
Date Posted: Jul 10, 2013 @ 7:50pm
Posts: 5