Jeff⑬Dahmer [HR] Jul 5, 2013 @ 10:29am
An error occured while updating L4D2 (Disk read error)
This has been tearing my nerves for hours now. So basically, 5 hours ago the game started normally...I joined a scavenge game with my friend and then the game just closed. Some weird crash...no error message, nothing. And when I went to start it up: "Disk read error". The game refused to start.

- BLOB files (already tried that)
- Integrity of game cache (Yeppers)
- Deleted the whole game (but then...another thing happened)

The game installed from the disk extremely quickly, and immediately after like 10secs went into updating. But it keps PAUSING constantly...and when it would download, it pauses again and resumes to download another 1.2GB's of update content I guess. It's like endless updates with annoying freezes in between.

Anyone experiencing this? Or know how to fix it...My disk is squeaky clean, and I've never encountered this sort of issue...
Showing 1-8 of 8 comments
< >
[AC|R]tommykyle Jul 5, 2013 @ 10:32am 
try a full install from steam maybe a conflict with files on disk and update
Jeff⑬Dahmer [HR] Jul 5, 2013 @ 10:35am 
Hmm...I'll try. I just read that the "appcache" folder could be causing it. Since, sorry, forgot to mention...the "left4dead2.exe" is nowhere to be found within the folder...
Castrate-it Carl Jul 5, 2013 @ 10:56am 
I feel your pain bruh.
Jeff⑬Dahmer [HR] Jul 5, 2013 @ 11:36am 
Downloading the game now from steam, since the disk attempt failed miserably. Oddly enough (as things werent so screwy before) the game started a few moments ago but then displayed this: "Entry point not found in some dll.file." (can't remember which though) It refered to the left4dead2.exe, which wasn't missing. And then it would get stuck on the loading screen. Well...I'll let ya know if I fix it after a few more...LONG hours....
Jeff⑬Dahmer [HR] Jul 5, 2013 @ 2:15pm 
Yeehaw! It did the trick (thank you tommykyle) Installed from steam and for now...the game seems to run great.
Kuro The Umbreon Oct 22, 2013 @ 8:38pm 
I am having this issue and i installed it FROM steam store no disk used so yea.......

(If your going to release a game make sure it works otherwise don't release it period)
Jeff⑬Dahmer [HR] Oct 24, 2013 @ 2:32am 
Originally posted by Skyler The Shy:
I am having this issue and i installed it FROM steam store no disk used so yea.......

(If your going to release a game make sure it works otherwise don't release it period)


Well the only workaround I can think of now is a full reinstall as tommy suggested...this is the most annoying error among others (it happens for no reason whatsoever) Sorry for your troubles, it's so damn nerve wrecking.
PierreAlfa Apr 21 @ 3:50pm 
bump
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Jul 5, 2013 @ 10:29am
Posts: 8