Left 4 Dead 2

Left 4 Dead 2

View Stats:
Hola Uriberto Jul 4, 2013 @ 7:18pm
Workshop Addons re-downloading bug
Hi all,

Yeah, I know this is an old topic and I will keep it as short as I can.

First, has there been any official word from VALVe regarding this issue? It is annoying as hell to wait for all add-ons to re-download every time you open up the game, and it's been a long time since this issue was first introduced, so I'd expect there was word from VALVe about it.

Second, if there is word, could you post link in reply? I searched a lot but I can't find it.

Third, is there any solution to this other than unsuscribing after download? I remember there was something about removing a folder but I can't seem to find it, I read it at work some days ago and I remembered now that a friend wanted to play with me due to the free weekend.

Fourth, is there any place where we could post this? Any bug report site for Left 4 Dead 2? Because this issue is not only happening to me. And VALVe really needs to fix this, or at least acknowledge it and make the note available and easy to find.

That'd be all.

If anybody could answer I'd be grateful. Specially since I know this post will be hidden among many others due to the free weekend. But whatever, I needed to write this down before I forgot.

Thanks!
< >
Showing 1-15 of 16 comments
Hugh Egg Aug 3, 2013 @ 12:04am 
I havent run into this bug until tonight.

Normally, when starting up the game. It takes around 10-15 seconds for all the add-ons to load. But now as I type this, the game is re-downloading every add on I have.
KaiserFu Aug 3, 2013 @ 6:17am 
Same issue here. The campaign mods take forever to re-download. It used to take me about 5 mins for all the mods to dl, but now it's just crazy. The mods are what what brought me back to LFD2 and have some fun, but this issue is hindering that for sure.
lucifertdark Aug 3, 2013 @ 6:23am 
I've seen this bug in other games, I don't think it's L4D2 but more a Workshop bug.
Stefanonimo Aug 3, 2013 @ 9:10am 
I have the same problem with campaigns... the game crash and then reloads when I restart the game
(-=Dr Ellis=-) Aug 3, 2013 @ 4:24pm 
all of my add-ons are reloading every time too
Mathias Berwig Oct 1, 2013 @ 7:17pm 
No solution yet?
GothicSimmer Oct 2, 2013 @ 12:48am 
I had this issue since the Workshop was introduced. I was tired of the re-download bug so I had unsubscribed the add-ons but I did favorited them incase I wanted to download them again.
Downya Oct 6, 2013 @ 12:42pm 
i've solved the problem by downloading the custom maps at http://www.l4dmaps.com/
they are the same, you just need to unpack the file in the 'addons'-folder; and it works without re-downloading.
Last edited by Downya; Oct 6, 2013 @ 12:46pm
Hola Uriberto Oct 6, 2013 @ 1:45pm 
Another workaround is to copy the addons once they are downloaded into the "addons" folder outside the "workshop" folder. Although THIS IS NOT A SOLUTION, VALVE, just a workaround. I expect this to be fixed soon, this cannot go on, it's a very old error.
Mathias Berwig Oct 6, 2013 @ 3:15pm 
Yeah, I tried to copy the workshop addons to the outside folder, this worked, but I haven't support for new updates. The only mode I had success to install addons from workshop with the updates is downloading all packets inside the game, on main menu.
Folie à deux Oct 2, 2015 @ 6:47pm 
2013 to this day... It will never be fixed...
Neon Feb 14 @ 5:55pm 
Originally posted by Folie à deux:
2013 to this day... It will never be fixed...
ever
Originally posted by Neon:
Originally posted by Folie à deux:
2013 to this day... It will never be fixed...
ever
2016 and counting. Uninstalled the game long ago because of this.
Jacqueline Feb 14 @ 10:35pm 
it's not an bug, the idea behind the workshop is basically a mandatory auto update check when you start your game, it's a good idea if people only have a few and small addon,

but if you have 50+ addon and many big one, it's not so much,

and you need to wait when start the for l4d logo next to "add-ons" stop spinning before clicking on the add-ons or start a game,

because when you launch the game you need to wait for l4d logo next to "add-ons" stop spinning before clicking on the add-ons or start a game, if one addon check freezes then you only get the ones that have been checked and those that are in the addon folder

so if you have a addon that don't need to be fixing or creator doesn't have any plan of doing a update, you should move those addon from "left4dead2\addon\workshop" folder into the "left4dead2\addon" folder and unsubscribed to them, that way you are not waiting for so long before you can start your first game and if the addon gets taken of workshop you still have it.
Originally posted by Jacqueline:
it's not an bug, the idea behind the workshop is basically a mandatory auto update check when you start your game, it's a good idea if people only have a few and small addon,

but if you have 50+ addon and many big one, it's not so much,

and you need to wait when start the for l4d logo next to "add-ons" stop spinning before clicking on the add-ons or start a game,

because when you launch the game you need to wait for l4d logo next to "add-ons" stop spinning before clicking on the add-ons or start a game, if one addon check freezes then you only get the ones that have been checked and those that are in the addon folder

so if you have a addon that don't need to be fixing or creator doesn't have any plan of doing a update, you should move those addon from "left4dead2\addon\workshop" folder into the "left4dead2\addon" folder and unsubscribed to them, that way you are not waiting for so long before you can start your first game and if the addon gets taken of workshop you still have it.
It's not that it's checking. It's that it's re-downloading. Could wait for over an hour and it would still be downloading.
< >
Showing 1-15 of 16 comments
Per page: 15 30 50