Left 4 Dead 2

Left 4 Dead 2

View Stats:
failed to load the launcher dll (null)
Since the latest update i receive this error message all the time when i try to run the game. Before this i could run it without any errors or glitches. So i must say thanks to valve for keep♥♥♥♥♥♥♥♥all of their good games to get more and more money. You're damn cool. I hope you will add some hats to L4D2 soon. It would be nice but luckily i won't take any part of it since i cannot run this freakin game anymore. So i think I'm happy now but i hope you feel the s(h)ame.
< >
Showing 1-15 of 18 comments
Tiziano Lugaresi Jul 3, 2013 @ 8:21am 
I'm having the same issue here. Could the lack of SSE2 have something to do with it?
who shot Marvin? Jul 3, 2013 @ 8:39am 
Yes if valve changed something in the game engine. I had the same error message when i tried to launch Portal 2 but i could play with L4D2 before this crap goddamn it. Anyway try to delete the bin folder or even try to verify game caches. https://support.steampowered.com/kb_article.php?ref=6897-DMYX-9004 It didnt't solve the problem for me but maybe it will solve it for you.
Tiziano Lugaresi Jul 3, 2013 @ 9:43am 
Didn't for me either. I suppose the error could be in engine.dll. Also the Left4Dead2 Authoring Tools no longer work (0xc000001d).
Upon closer inspection, it looks like these programs are trying to access files with idiotic names, such as 巙矀ૠŠ.dll or 巙矀ૠ8?.dll. This happens right after loading usp10.dll, so my guess is there are some incompatibilities with unicode characters in the game dlls. If that were true, this should be related to the OS version.
Last edited by Tiziano Lugaresi; Jul 3, 2013 @ 9:57am
who shot Marvin? Jul 4, 2013 @ 10:49am 
I don't know pal and to be honest i don't give a damn anymore. The update came out days ago but still no fixes around. Thanks again valve.
who shot Marvin? Jul 7, 2013 @ 2:06pm 
bump
Rudofaux Jul 17, 2013 @ 1:58pm 
I myself am running trough the same problem. I have tried verifying the cache, uninstalling & reinstalling a number of times but to no avail. My problem happened at the same time as OP's post. (around July 4th to be exact)
[HOOD]-Sniper666 Jul 18, 2013 @ 9:10am 
i have a new brand pc so i installed steam then i installed l4d2 but my neighbor has had this game since it came out and he has had no problems with it so that makes me wonder if it isnt the new update ill ask him why his is still running and then ill post his answer up here
[HOOD]-Sniper666 Jul 18, 2013 @ 9:23am 
it says dll (null)
Rudofaux Aug 18, 2013 @ 11:20pm 
The sad thing is the only thing VALVe tells us is to check for file discrepancies &/or reinstall. As if I haven't done that before.
who shot Marvin? Aug 19, 2013 @ 4:55am 
That's right they are making a joke of us. Anyway after i posted this i tried to play with the 1st l4d and it froze in the main menu. But there was a steam update a few weeks ago which solved this problem to me. I haven't tried the 2nd game yet but maybe it will work fine too. We'll see..
Last edited by who shot Marvin?; Aug 19, 2013 @ 4:56am
Sage Sep 4, 2013 @ 4:27pm 
Having the same problem and I'm still searching for answers. I'm assuming this is Valve's fault with their consistent updates. At first I restarted my computer when this problem came about, and originally it just failed to load. That fixed it, and that was yesterday. Today however nothing has worked and the problem has evolved into "Failed to load the launcher dll" which explains nothing at all. Has anyone come up with a solution or do we have to sit around and wait for Valve to fix this?
Ripley Sep 23, 2013 @ 7:15am 
Its happening to all SSE 1 people now. Tf2 got hit, Left 4 dead 2 now, HL2 Probably too, What da♥♥♥♥♥♥valve? srewing us over much
who shot Marvin? Sep 23, 2013 @ 8:23am 
steambox is coming.. we need a new platform if we wanna play with these craps again.. do you get it? *spit*
der dritte im bunde Sep 25, 2013 @ 12:14am 
Dear community,

i visit your discussion as delegate from CS:S fraction.

We also have the same issue :

1.) error report - failed to load the launcher dll (null)
2.) possible reason - update from 17th does not support sse performance machines

First, please be so kind and gather your votepower in one mainchat; i would like you to prefer this one.

We are in discussion in CS:S forum about it :
http://steamcommunity.com/app/240/discussions/0/864979008727071632/

Also there are some gamer in TF2 about it :
http://steamcommunity.com/app/440/discussions/0/864977563973658153/#p3

Also in half-life 2 :
http://steamcommunity.com/app/320/discussions/0/864979455422065247/

Perhaps it will be witted to incorporate.

Let me hear your position and let us talk before opening new threads
Rudofaux Sep 25, 2013 @ 10:53am 
One thing I'm trying to wrap my head around. Why would they have to remove the SSE capability when it worked fine before?
< >
Showing 1-15 of 18 comments
Per page: 15 30 50

Date Posted: Jul 3, 2013 @ 8:01am
Posts: 18