William.Riker ☁ Jul 3, 2013 @ 2:19am
L4D2 dedicated server - your server is out of date
I run verify and still same message, valve update client and not winows dedicated server?
Showing 1-15 of 17 comments
< >
Cute little strawberry ♥ Jul 3, 2013 @ 3:03am 
Since the update yesterday, dedicated servers don't work
They should fix it soon
OverlordTomala Jul 3, 2013 @ 3:10am 
Glad I'm not the only one.
AfterShock Jul 3, 2013 @ 6:12am 
Originally posted by KMA:
https://developer.valvesoftware.com/wiki/SteamCMD

doesn't fix the issue, I just did a clean install of my l4d2 server and it spams the same message, steamcmd installs the version prior to the latest update.
KMA Jul 3, 2013 @ 8:12am 
i'm a bit new to this but i have a dedicated server on another pc and its running. I recently started messing around with dedicated servers for this game. i'm not "the man" at this yet.
AfterShock Jul 3, 2013 @ 8:27am 
leave it be for now, it appears that once you update you cannot join your own server, steam validation rejected ♥♥♥♥♥♥♥♥.this steampipe is a pile of crap
AnGeR Jul 3, 2013 @ 8:31am 
Indeed, full of cracp. They started to build the house by the roof, nonsense :S
PeopleNeedToGrowUp Jul 3, 2013 @ 1:20pm 
same problem here!!
☠Jack☠ Jul 3, 2013 @ 1:32pm 
Problem solved now.
Run SteamCMD again. The server is reconfigured.
Bulldogs Jul 3, 2013 @ 2:48pm 
Originally posted by Slippery ( . Y . ):
Originally posted by KMA:
https://developer.valvesoftware.com/wiki/SteamCMD

doesn't fix the issue, I just did a clean install of my l4d2 server and it spams the same message, steamcmd installs the version prior to the latest update.

That is because valve have released a broken server to the public, we have to wait until they decide to fix it, the new steam CMD / steampipe for l4d2 servers was obviously not tested properly by valve before release, but really what's new - valve seem to make a habit of breaking l4d2 client and servers with updates.

Running tracerts and pings (to official servers) shows it is an issue on their end aswell.

It is apparently fixed now, jsut re run the steam CMD again as Jack above says.
Last edited by Bulldogs; Jul 3, 2013 @ 8:23pm
William.Riker ☁ Jul 3, 2013 @ 11:15pm 
still same problem, restart PC, update L4D2, I dont use steamcmd, Im using HLServer from this http://forums.steampowered.com/forums/showthread.php?t=1381634&highlight=dedicated+L4D2
could please help how to run update? thank you


EDIT: i find list of steamcmd ID app https://developer.valvesoftware.com/wiki/Steam_Application_IDs

L4D2 dedicated server for win ID = 561
I will try it...

EDIT2: 561 not work, 560 not work :-(


EDIT3: ID = 222860 now install :-)
Last edited by William.Riker ☁; Jul 3, 2013 @ 11:31pm
Jeroen Beekman Jul 4, 2013 @ 3:26am 
Valve please update the dedicated server. Cannot test my maps with my friends.
Last edited by Jeroen Beekman; Jul 4, 2013 @ 3:27am
OverlordTomala Jul 4, 2013 @ 4:53am 
Originally posted by William.Riker:
222860 now install :-)

Thanks for the tip! Downloading right now with fingers crossed.
William.Riker ☁ Jul 4, 2013 @ 5:20am 
Originally posted by OverlordTomala:
Originally posted by William.Riker:
222860 now install :-)

Thanks for the tip! Downloading right now with fingers crossed.

IT IS WORKING FOR ME :-)


sourcemode a metamod work too :-)
disable this plugins: basecomm.smx and basetriggers.smx
from left4dead2\addons\sourcemod\plugins
move to left4dead2\addons\sourcemod\plugins\disabled\
Last edited by William.Riker ☁; Jul 4, 2013 @ 5:22am
gotbanned Jul 10, 2013 @ 3:28am 
This Update spoiled everything. Not only my Dedicated server running, but also my rented server also not running.
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Jul 3, 2013 @ 2:19am
Posts: 17