Left 4 Dead 2

Left 4 Dead 2

View Stats:
Reggae Shark Jun 24, 2013 @ 5:14am
Console
Hello,how to select a shortcut for the console,while you're playing?
< >
Showing 1-9 of 9 comments
Jorgen Jun 24, 2013 @ 6:42am 
The only way to change the shortcut for the console while playing, is to open the console by using the default key ("~" ou "` ") and then using the following command: bind "key_you_want" "toggleconsole"
save nostalrius Jun 24, 2013 @ 8:20am 
Type in bind t *sample* "z_spawn witch"
Reggae Shark Jun 25, 2013 @ 2:06am 
The problem is that I DON'T have a shortcut. As I start the game,there is the console but when I click somewhere it disappears and I don't know how to make it appear again.
riveniswaifux Jun 25, 2013 @ 3:44am 
  • Start the Game and go to the options menu. Click on the Keyboard/Mouse Tab and click on the "Allow Developer Console" option and click enable and close the Game.
  • Open your autoexec.cfg/config.cfg
  • add this line bind "F10" "toggleconsole" (it doesn't have to be F10 you can bind the console on any button)

cfg folder:(C:\Program Files (x86)\Steam\SteamApps\common\left 4 dead 2\left4dead2\cfg)

Or:
  • Start the Game and go to the options menu. Click on the Keyboard/Mouse Tab and click on the "Allow Developer Console" option and click enable and close the Game again.
  • add "-console" to your L4d2 start options
  • start the game again, you will see the console
  • Type bind "KEY" "toggleconsole in the console and press enter. You can press the "KEY" to open the console inGame
Last edited by riveniswaifux; Jun 25, 2013 @ 3:45am
Reggae Shark Jun 25, 2013 @ 12:43pm 
Thanks JarJar. Now it works but I have just another little question. Once I have closed it in the main screen,when you can select how to play (single player,multiplayer,versus....) how can I make it appear again?
riveniswaifux Jun 26, 2013 @ 3:18am 
it happens to me, too.
I move the mouse to the text in the left side (options; close game; new blog .. etc.) and then i press f10 if it doesn't appear i just move the mouse over the text a little bit more untill it appears :p
I have your same problem legitboy_13, but in my case the console never re-appears. It does when I'm playing but not in the main screen and I can't start add-on maps. Any solutions?
riveniswaifux Feb 16, 2014 @ 12:35pm 
You should be able to start add on maps in the menus, you click on "choose/play addon campaign" and you get the add on campaign+map selection. Or you can go into a random campaign (singleplayer) and open up console and write "changelevel xxx" or "map xxx".
Thnx! Some maps require commands to star them, you can't do it with "play addon campaign". But i didn't know about the changelevel and map command.
< >
Showing 1-9 of 9 comments
Per page: 15 30 50

Date Posted: Jun 24, 2013 @ 5:14am
Posts: 9