Spiffy Jun 1, 2013 @ 3:21pm
L4D2 won't launch!
I don't know if anyone else is encountering this issue but, when I click the play button, the little box stating that L4D2 is preparing to launch pops up and then just disappears. The game won't start whatsoever. I've tried deleting the .blob files and all that but nothing is working.

I don't know if this is of any consequence but whenever I try to verify the cache files, there is always one file that is missing or something like that.

I used to play this game quite a bit. Does anyone know if this could be related to the recent beta activity?
Showing 1-15 of 17 comments
< >
Xz ReDeMs zX Jun 1, 2013 @ 4:37pm 
reinstall the game & leave beta that will work
Kuuhaku Jun 1, 2013 @ 4:57pm 
verify the integrity of the game cache
Kuuhaku Jun 1, 2013 @ 4:58pm 
I've had a similar problem trying to play single player
Spiffy Jun 1, 2013 @ 7:47pm 
i haven't joined the beta.
Spiffy Jun 1, 2013 @ 7:48pm 
how do you leave it? And verifying doesn't do anything.
APerfectCircle Jun 2, 2013 @ 3:04am 
Mine won't run properly either! I recently did a fresh install of windows, copied all steam games over, I validated the game files and it launches the intro which I press esc, then it says loading for a few moments before quiting :/
Lord Francis Jun 2, 2013 @ 8:15am 
give it some time to start
Spiffy Jun 2, 2013 @ 9:45am 
I have, it doesn't jump to the loading screen for me or anything. I've even watched the task manager the game just closes out after preparing to launch. I've been jonsing for some good zombie killing action for like a week now.
APerfectCircle Jun 2, 2013 @ 4:22pm 
Okay, I finally successfully validated the files and it fixed 1 file and now it works fine. I hope you solve your problem too gahji
Spiffy Jun 2, 2013 @ 7:44pm 
It hasn't
Chemical Man Jun 5, 2013 @ 7:05am 
I have a similar problem, but I crash when I try to play single player. Defragmenting and redownloading doesn't work, and it says 1 file failed to verify when I try to verify the files
✯Kat Mercury✯ Jun 5, 2013 @ 9:47pm 
I've had the same problem. Hasn't worked for me for about 2 weeks. >:(
Spiffy Jun 9, 2013 @ 11:39am 
Same here, Shadow. I finally got an email saying something like try deleting the steam.dll file and the clientregistry.blob and then restart steam and it should update and work but I haven't tried it. I'm taking a break from steam for awhile.
Richard Nixon Aug 21, 2013 @ 3:00am 
My Left 4 dead 2 is also not working. every time I run it nothing happens!
FakeTim {MA} Aug 21, 2013 @ 5:38am 
Same problem here. Did a fresh install, verifyed the cache a few times. Very annoying....
Showing 1-15 of 17 comments
< >
Per page: 15 30 50
Date Posted: Jun 1, 2013 @ 3:21pm
Posts: 17