Left 4 Dead 2

Left 4 Dead 2

View Stats:
ubermange Feb 15, 2013 @ 12:25pm
i get bsod after intro at title halp please
< >
Showing 1-7 of 7 comments
ubermange Feb 15, 2013 @ 12:36pm 
C=64 Feb 15, 2013 @ 1:08pm 
When asking a question, you really need to give more information about your PC specs and software such as drivers etc.
ubermange Feb 15, 2013 @ 1:10pm 
k heres specs

my video card is a ADM radeon HD 7670M
my OS is windows 7 64 bit
i have 455148 mb
4 logical processors
and 2 physical processors
my primary VRAM is 1024mb
that enough?
C=64 Feb 15, 2013 @ 2:29pm 
cool, thanks.

Being a laptop the first thing i would look at is the drivers for that gfx card, i know AMD have new beta ones out that vastly improve stability they can be grabbed from here:


Also check that the latest DX 9.0xx is installed (can be found here,yes i know the gfx card is DX11 but DX9.xx is a seperate layer and is needed)): http://www.microsoft.com/en-au/download/details.aspx?id=8109

The third thing to check if none of the above help, is to disable any anti virus applications or tell your Anti Virus to ignore / exclude the steam directory from scanning or heuristics, the default location for steam directory is C:\Program Files (x86)\Steam (on windows 7 x64bit which you currently have).

Optional things to try also:

Validate your GCF (Game cache files) a how to video guide is here: http://www.youtube.com/watch?v=FoOwlzleMjI

Also try disabling UAC (User Account control), a how to video guide is here:

You can also try disabling any background applications (especially skype) or other programmes that you might ahve running in the background such as teamspeak etc.
Ninjaforce Feb 15, 2013 @ 4:27pm 
Your computer broke it wasn't the game
ubermange Feb 15, 2013 @ 4:28pm 
i fixed it! but i can only run windowed mode
[eVo]SqueaKalop Feb 15, 2013 @ 5:37pm 
That happened to me with the same engine. I updated my BIOS, worked like a charm. :3
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Feb 15, 2013 @ 12:25pm
Posts: 7