Pipesnake Dec 27, 2012 @ 10:12am
Left 4 Dead 2 Lag on "Official Servers"
Hi folks. Anyone else getting lag lately on L4D2 "official" servers? I'm trying to figure out if it's something to do with my comp or something to do with the servers. My computer is an i5 2500K with a GTX 570, 8 GB of RAM, Raid 0 drives, etc. My internet connection is roughly 80 Mbps. In other words there is no reason I should see lag like game play from that perspective. I've had no problems until recently, perhaps the last few weeks. I've tried rolling back various drivers, installing new ones, verifying game files, defragging game cache, reinstalling the game, etc. I've tried disabling v-sync and disabling mutl-gpu rendering. During game play my CPU never gets above 30 percent, nor does mem usage. Ping times in these games are usually less than 50 ms. Frame rate sticks at 60 with v-synch on and goes much higher with it off. In game some others seem to notice the juttery play but some don't. Some notice my character being juttery or lag like. So anyone else seeing this? Any ideas? Thanks.

Pipesnake
Showing 1-6 of 6 comments
< >
Wolf's Blood Jan 21, 2013 @ 3:43pm 
i have the same problem, and its only been happening lately.. but whenever im on multiplayer it does that
Kai Hiwatari Jul 30, 2013 @ 12:01pm 
There is lag in every server and game STEAM YOU NEED TO EXPAND EVERYTHIING TO GET RID OF ALL THE LAG!!!!!!!!!
ITS 2015, CLEAR YOUR BLOCKLIST! Jul 30, 2013 @ 1:47pm 
l4d2 bad regs servers, and bad pings... classic do with it.
jesus Sep 21, 2013 @ 12:51pm 
Ive been having similar problems. Ever since an update a few months back, I get spikes of lag in game. All my resources are at 50 to 70 % and then when the lagg hits, my resources actually drop to 30 or 40 % used. I have reinstalled, rolled back drivers, uninstalled everything, tried installing on a new OS, I cannot find the reason besides the game itself is having issues with my hardware. I do not have another computer at my home that can play this game unfortunately or I would try that out too.
Dr Chaos MK Sep 22, 2013 @ 6:33pm 
I seem to have good experiences with official dedicated. Although I make damn sure my setting within Steam are correct. Like internet speeds, region settings, ect....
Kai Hiwatari Sep 22, 2013 @ 7:41pm 
yeah no i can't play the game with my friends they are having the same problem as me
and we go towards the local servers and away from the dedicated or best dedicated servers and it still lags. they need to fix it but when you go on a server like noobtube its not so laggy but still there is so many servers up and running they need to up the speed of the game to fit all of the servers that are popping up.
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Dec 27, 2012 @ 10:12am
Posts: 6