Left 4 Dead 2 > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Яandomman96 18 Ιαν, 2013 @ 5:21μμ
Workshop Add-ons not loading on Macs
I added two new add-ons from the workshop to day, and they will not load. I quit and started the game back up, unsubscribed and resubscribed in game. Can someone help me?
Εμφάνιση 1-15 από 19 σχόλια
< >
docrobc 18 Ιαν, 2013 @ 5:47μμ 
What the hell? The same is happening to me. Subscribe to add-ons. Add-ons download. Quit game. Restart game. No add-ons. Go back to workshop. All items checked. Does this work on Macs or not? If not, why not say so up front?? If not, WHY NOT??? It really sucks when you supposedly support Macs, but then only do a half-♥♥♥♥♥ job of supporting Macs. I would almost you just don't bother!
blackletum 18 Ιαν, 2013 @ 6:32μμ 
Well, this is happening to me on my Win7 machine too, so maybe it's not an issue of just Mac's?
Яandomman96 18 Ιαν, 2013 @ 6:51μμ 
GABEN!!! GET OFF YOU BUTT AND FIX THIS!!!!!
OHMSBY 18 Ιαν, 2013 @ 9:07μμ 
The problem is that there is now a workshop folder within the addon folder, and for whatever reason, the game isn't picking up on it.

I'm sure there will be a fix, but in the meantime, you'll have to copy everything in the workshop folder and paste it back into the addons folder, and you'll have to do it again everytime you download another mod or if a mod gets updated.

Here's the directory for the addon folder:
*your name*/Library/Application Support/Steam/SteamApps/common/Left 4 Dead 2/left4dead2/addons
blackletum 18 Ιαν, 2013 @ 9:19μμ 
Ha, such a simple fix, you'd think they would've figured this out before this was released. Thanks for the temp fix though
blackletum 18 Ιαν, 2013 @ 9:35μμ 
Even then, after copying them into addons, they don't work. Checkmarked in L4D2 and everything. This is getting frustrating.
Kern 18 Ιαν, 2013 @ 10:04μμ 
Thanks for the tip OHMSBY. Works perfectly now!
blackletum 18 Ιαν, 2013 @ 10:11μμ 
Well, crap. Apparently my L4D2 hates me. I've tried this on my laptop AND my desktop and it screws up on both.
bhaines 22 Ιαν, 2013 @ 6:19μμ 
OHNSBY is that in the start menu because if it is then i dont have a folder like that
[HBS OFFICER] Flame Haze 22 Ιαν, 2013 @ 6:36μμ 
Αναρτήθηκε αρχικά από bhaines:
OHNSBY is that in the start menu because if it is then i dont have a folder like that
he's talking bout macs
bhaines 22 Ιαν, 2013 @ 6:42μμ 
ooooo
[HBS OFFICER] Flame Haze 22 Ιαν, 2013 @ 6:43μμ 
Αναρτήθηκε αρχικά από OHMSBY:
The problem is that there is now a workshop folder within the addon folder, and for whatever reason, the game isn't picking up on it.

I'm sure there will be a fix, but in the meantime, you'll have to copy everything in the workshop folder and paste it back into the addons folder, and you'll have to do it again everytime you download another mod or if a mod gets updated.

Here's the directory for the addon folder:
*your name*/Library/Application Support/Steam/SteamApps/common/Left 4 Dead 2/left4dead2/addons
thanks ohmsby i'm gonna spread it around (of course u deserve the credit :D)
Яandomman96 22 Ιαν, 2013 @ 6:44μμ 
So, it's working now. Just do it the same way you would with Minecraft texture packs.
docrobc 25 Ιαν, 2013 @ 10:53πμ 
Moving to that folder works for most add ons, but I have found that for some reason if the name ends in a number, it still won't show up unless I rename the file to take the number off the end. But even that is not consistent. More steam/valve weirdness I guess.
Sup? 25 Ιαν, 2013 @ 11:59πμ 
will when i click add-on button and click one of the dlc button it froze my screen!!
Εμφάνιση 1-15 από 19 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 18 Ιαν, 2013 @ 5:21μμ
Αναρτήσεις: 19