Dr.Wily Jan 18, 2013 @ 1:44pm
addons won't work
today i saw l4d2 had a workshop so i decided to download some stuff from the workshop then i opened the game and when i went to addons they didn't show up can you help me?
Showing 1-15 of 16 comments
< >
ekan Jan 20, 2013 @ 10:11am 
Same problem here
Rocket Salesman Jan 20, 2013 @ 10:14am 
I have the same problem. Additionally, L4D no longer connects to multiplayer. Single Player works fine, but when I try to connect to an online game, the connection crashes everytime, although my steam connection is fine and wifi works fine.
#Octothorpe Jan 20, 2013 @ 10:47am 
I got the same thing so you guys aren't alone, also it says Left 4 Dead 2 didn't sync with the Steam Cloud.
Dr.Wily Jan 20, 2013 @ 12:09pm 
yeah but this is with bots
☣ToatalPwnage☣ [SMP] Jan 20, 2013 @ 12:12pm 
some addons can NOT just be clicked and installed with the add-on installer. with some of them you have to actually go to the folder they are stored in and drag and drop them in there.

and if you game is not syncing try verifying your files in properties.
Last edited by ☣ToatalPwnage☣ [SMP]; Jan 20, 2013 @ 12:13pm
Ðєєp Jan 20, 2013 @ 4:25pm 
I had to restart my game for some of my addons to show up.
☣ToatalPwnage☣ [SMP] Jan 20, 2013 @ 4:54pm 
ok just to be more acurate what addons and we taking about and not working in what situation? single player, vurse, and like map addons or weapons skins?
[Senpai] Pumpernickel Jan 20, 2013 @ 8:55pm 
Same here. The addons that I had left clicked on before this update show up in game but all my others ones such as skins and the like are unaccessible now. I can't choose between skins for weapons and items anymore, whether to run a campaign or not; nothing. Apparently there is supposed to be an "Addons" selection in the menu? My friend can see hers plain as day and mine is missing. Heck, I haven't even been on since the update and now this? Fix.
Jeff The Assassin Jan 20, 2013 @ 9:37pm 
i agree fix it please
Fluffy Madness Apr 21, 2013 @ 2:08pm 
mine alittle diffrent. when installed the game everything work fine add on an everything but when i turn the computer off or restart. it act like i never downloaded anything from the workshop. or sub anyone. any clue on what it my be? (the only way i can fix this is i reinstall the game.. an i dont feel like doing that.. at all.)
[Senpai] Pumpernickel Apr 21, 2013 @ 7:34pm 
Thanks to some dialogue on a L4D2 video on Youtube, I found out that Rayman's Mutation mod actually disabled the add-ons section for me so I unchecked it. Whether or not that issue has been addressed in a fix of his, I don't know.
Wolfmoose Apr 23, 2013 @ 8:51am 
I was just recently struggling with the same problem but I've now fixed it. At first I tried moving around the files from the workshop folder to the addons folder but that did not work. I also reinstalled the game completely (!) and verified files etc. What did work however was deleting a file in the left 4 dead 2/left4dead2 folder called "addonlist.txt". I looked in it before deleting it and noticed it had a few "old" addons I used before the workshop existed. After deleting the file and starting the game all the addons popped up fine in the list!
checklist618 Jun 22 @ 6:44am 
My add-ons show up just when I check them they don't work
sophia Jun 22 @ 6:48am 
Originally posted by checklist618:
My add-ons show up just when I check them they don't work

SP or online on dedicated servers
=EGC= Solidus Jun 22 @ 8:36am 
I had a similar problem a few months ago, all the L4D2 Workshop files just stopped working and the game crashed. What I did was I deleted everything from the workshop, and downloaded them regularly from http://www.gamemaps.com/l4d2/ then everything worked fine.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50