Buzz Dec 18, 2012 @ 12:16pm
Left 4 Dead 2 Crashes
I've had this problem for some time, whenever I try to load the game it crashes as the powered by source screen fades out. I had the problem before, it fixed itself (somehow) and has now come back. I've tried uninstalling and reinstalling and verifying the game cache. Nothing seems to work.

As a side note, if I try to skip past the loading screens it just freezes anyway. The only way to close it when this happens is through task manager as it comes up as "not responding"
Showing 1-15 of 18 comments
< >
alaeidmeu Dec 19, 2012 @ 1:59am 
i have the same problem as i can see alot of people do there is not working answer tho if you manage to find one please contact me .
Flashboy686 Dec 19, 2012 @ 2:36am 
i have this problem too! it's mass probem or not&
alaeidmeu Dec 19, 2012 @ 11:28am 
yea but is there any solutions ?
Buzz Dec 20, 2012 @ 8:27am 
If I even find a solution, I'll be sure to post it!
Hydra_360ci Dec 20, 2012 @ 9:49am 
If -novideo
https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947
get you through then something is wrong with the video playback.

The other crash I know about is if a custom campaign you put in the addons folder is corrupt. Everything in the addons folder gets loaded into L4D2 right before the main menu screen. So, if one is bad the game crashes right before the main menu comes up. (so, try removing all the ones you have, in there. Reinstallation wouldn't fix that, because the uninstall process does not mess with the addons folder. Next time you go that route, manually delete all the game's folders, after uninstalling.)
Last edited by Hydra_360ci; Dec 20, 2012 @ 9:54am
alaeidmeu Dec 21, 2012 @ 12:02pm 
tryed , no fix there the game works it just crashes out of the blue is not a patern or smth and i cant even end process
Hydra_360ci Dec 21, 2012 @ 2:16pm 
If it's out of the blue, it's likely the PC. Video card or the CPU could be overheating, or t PSU is lacking clean power (aka: a generic PSU).

Or... you're overclocking.
RΞV [A] StonedBooM Dec 21, 2012 @ 3:02pm 
respect Hydra.... you allways trying to help other players.... really nice to see
Buzz Dec 25, 2012 @ 1:38pm 
Originally posted by Captain - StonedBooM:
respect Hydra.... you allways trying to help other players.... really nice to see

LOL!

But no, it's not random, it's the same point every time, unless I try to skip the company logos, in which case it freezes then.
HayaL33T Dec 26, 2012 @ 12:51am 
same here
J.M.C. Dec 26, 2012 @ 12:58am 
System compatibility. ur system info is: cpu dimm vga ? And we talk about it. file defrag, game cahe defrag should be updated.
J.M.C. Dec 26, 2012 @ 12:59am 
Originally posted by alaeidmeu:
i have the same problem as i can see alot of people do there is not working answer tho if you manage to find one please contact me .
Contact me.
alaeidmeu Dec 28, 2012 @ 10:43am 
okay m8 added you

Originally posted by Dragonforce Kin:
Originally posted by Captain - StonedBooM:
respect Hydra.... you allways trying to help other players.... really nice to see

LOL!

But no, it's not random, it's the same point every time, unless I try to skip the company logos, in which case it freezes then.
the_delas Mar 31, 2013 @ 12:16pm 
Hi everyone,

I have exactly the same problem but i didn't see any real answer.
Have you all give up to play this game or did you find the solution ?

If the second, what is it please ?
alaeidmeu May 6, 2013 @ 11:01am 
well i did reinstall it 3-4 times
and how it works
Showing 1-15 of 18 comments
< >
Per page: 15 30 50
Date Posted: Dec 18, 2012 @ 12:16pm
Posts: 18