[KWMG] gNOOBdragon Dec 8, 2012 @ 1:06pm
L4D doesnt load. at all
been having this issue the whole night. already bought it. already had it installed and everything. and then i tried to play it. from right-clicking on the icon to going to library and clicking on play game. but it doesnt load. or it refuses to load. it shows that its there, somewhere but i dont see it at all. can anyone help?
Showing 1-4 of 4 comments
< >
herc (Banned) Dec 8, 2012 @ 1:10pm 
Maybe the guys crashing all the servers are bugging everyones l4d2 out xD.


I guess i shouldnt be a smartass.
Is the process running in the task manager?
Maybe it just crashed and you have to manually close it or restart your computer to fix it?
Last edited by herc; Dec 8, 2012 @ 1:13pm
[KWMG] gNOOBdragon Dec 9, 2012 @ 10:08am 
it doesnt show up in my activity monitor at all. already did the whole reboot, close and all. i'm on a mac btw. gahhh... still not loading.
toxic-Catastrophe Dec 9, 2012 @ 1:31pm 
is there a message or anything that pops up?
[KWMG] gNOOBdragon Dec 9, 2012 @ 11:01pm 
none whatsoever. all it said was preparing to launch left4dead2, then the small window opens and disappears. checked my activity monitor, showed nothing. so im uninstalling it now, deleted the local content and redownloading. argh.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Dec 8, 2012 @ 1:06pm
Posts: 4