Left 4 Dead 2 > Discussioni generali > Dettagli della discussione
Blazen 2 dic 2012, ore 10:17
Can't launch Left For Dead 2
downloaded the game days ago...still can't play it. No replies from support on email. I had no problem launching the free game today. Everything has been checked. Drivers, etc. Can't anyone help??
Visualizzazione di 1-15 commenti su 29
< >
UselessGamer 2 dic 2012, ore 13:06 
Ive been having the same problem as well.
Hydra_360ci 3 dic 2012, ore 7:28 
Need more info and things you've already tried. Such as verifying cache'.
Blazen 3 dic 2012, ore 18:00 
Intel Core i7 - 2600 @ 3.4 GHz 10 GB RAM GeForce GT 530
Verified cache files (said they were all there), complete deletion and re-installation, installing Java, C++ runtimes, directX, tried updating video drivers, (currently up to date and so are other drivers). The box "preparing to launch" runs for a few seconds, disappears and l4d2 is not launched.
EnigmaticRunner 3 dic 2012, ore 18:58 
Any error codes/messages?
Blazen 3 dic 2012, ore 18:59 
Hydra_360ci 4 dic 2012, ore 7:24 
Try adding:
to the launch option line. (they both do the same thing.)

If it works then you have some sort of video playback problem with the game. And will likely crash at all pnion servers, as well; until you figure out how to fix the video codec problem.
Ultima modifica da Hydra_360ci; 4 dic 2012, ore 7:31
Blazen 4 dic 2012, ore 17:42 
I tried your suggestion and it didn't work. My graphics driver is up to date.Sorry, some kind of error has occurred: There was an error communicating with the network. Please try again later.
Blazen 7 dic 2012, ore 5:39 
Is anyone going to fix this problem? It is not on my end.
Blazen 7 dic 2012, ore 5:56 
ok....maybe its not on your end....but what the heck? other games work...just not lfd2....
TheMasterBlaster™ 7 dic 2012, ore 6:10 
When all else fails, copy your custom VPK's somewhere, uninstall L4D2. Manually delete the L4D2 directory (files left behind by uninstall). Restart Steam. Re-install L4D2. Run L4d2. If it runs OK, add back your VPK's.
It doesn't take that long and it can fix many things that verifying the game cache will not do.
Hydra_360ci 7 dic 2012, ore 6:37 
Support doesn't use Email to contact you. They use this:

I don't know what's wrong, because I never had a problem with L4D2 not launching, But it's on your end, because the majority don't have that type of crash.

What should be happening is the first time you hit play, Steam does that one time only preparing to install thing (where it verifies Frameworks and DirectX), then about 3 minutes later, the game starts. It runs some Logos and then the Intro video. Then it starts Source Engine and gives you a menu screen. It's most likely that your PC is halting at the preparing to install thing for whatever reason, UAC, Antivirus, or, Ports blocked via the router, or something.

(typical crashes is if you PC can't run the videos. thus -novideo will bypass that. The other is if the game plays the videos, but crashes as soon as you get to the main menu. Usually the cause is a corrupt user made campaign that you placed in the addons folder. Removing it fixes that crash. Also, uninstall does not get rid of the addons folder, so redownloading the game doesn't fix that sort of crash. You have to remove those custom campaigns, yourself. But your crash doesn't match either of those. Your crash sounds like Windows is blocking the program, or some sort of hardware issue.)

Disable your antivirus and firewall.

If you have a router, try it with your PC connected directly to the modem.

Try putting -autoconfig in the launch options.


-w 800

Try it in Safe mode with networking. (Press F8 after post but before Windows launches.)

You haven't modded windows or Steam? As in trying to force steam to use multiple HDD's or relocating My Documents to another HDD?

Also, you haven't installed a pirated version of L4D in the past? You'll have to remove it, if you have
Ultima modifica da Hydra_360ci; 7 dic 2012, ore 6:51
Flaming Akuma 7 dic 2012, ore 6:55 
effect doesnt change with safe mode, still the same... ive been helping her with teamviewer... tried the launch options, no change, and completely uninstalled every antivirus, disabled the windows firewall, and port forwarded the necessary ports to run the game... which are the 27000-27050 TCP/UDP
Blazen 7 dic 2012, ore 7:05 
please help him..he has spent hours on this problem
TheMasterBlaster™ 7 dic 2012, ore 7:08 
Trust me, do whet I recommended. Sometimes L4D2 just develops problems over time that only a re-install will correct. I have been playing this game for 3 years and this almost always corrects issues like you are describing.
Flaming Akuma 7 dic 2012, ore 7:09 
ill give it a try again...
Visualizzazione di 1-15 commenti su 29
< >
Per pagina: 15 30 50
Data di pubblicazione: 2 dic 2012, ore 10:17
Messaggi: 29