Left 4 Dead 2

Left 4 Dead 2

View Stats:
ΖΩΝ Dec 1, 2012 @ 6:02pm
disable lobby/menu music, leave game music on..?
As far as I can tell, the only way to turn down the lobby/menu music is to go to the audio settings and turn the volume down on "music" to 0... but then I don't get music in game. In particular, I want tank music.

I guess one option would be to find what file holds the lobby music and delete it, but I don't want to have to do that every update or game cache verification. But, if no other option, anyone know what that is?
Last edited by ΖΩΝ; Dec 1, 2012 @ 6:03pm
< >
Showing 1-3 of 3 comments
Azimuth Dec 2, 2012 @ 3:08pm 
You could set snd_musicvolume 0; in your autoexec.cfg to set music volume to be off by default and then also set a bind to turn it on/off by also placing the following in your autoexec.cfg as well...
bind "g" "musicnext";
alias musicon "snd_musicvolume 1; alias musicnext musicoff";
alias musicoff "snd_musicvolume 0; alias musicnext musicon";
musicoff;
You may have to edit the value to an integer betwen 0 and 1 (1=max volume) that you prefer.
Lemmers Dec 2, 2012 @ 8:48pm 
Best option is to find the lobby music files, but instead of deleting them, replace them with blank files and turn them into a .vpk. So even after validation and updates, the music files in the .vpk will always replace the menu music. If you search L4Dmaps for Main Menu Mute, you'll find somebody who posted this already, although it's not especially hard to make yourself. Although now I wonder if it's better to actually mute the files preserving their original lengths instead of replacing with blank files all together... I'll have to test that out.

This method can disable the five or so different lobby music tracks while leaving the ingame music untouched. But if anybody knows how to get L4D1 menu music behavior back (plays only ONCE and then doesn't loop), I'd love to know.
ΖΩΝ Dec 2, 2012 @ 10:35pm 
Right on. Thanks to both of you.
< >
Showing 1-3 of 3 comments
Per page: 15 30 50

Date Posted: Dec 1, 2012 @ 6:02pm
Posts: 3