Left 4 Dead 2

Left 4 Dead 2

View Stats:
Stuttering
Left 4 Dead 2 has been stuttering horrendously lately. I have tried lowering the settings, resolution, and whatnot, but is still stuttering and making it unplayable. I enabled the in-game FPS count and I got a range of 14-120. When no enemies, it ranges from 27-60 in a few seconds, and causes major hiccups, stutters, audio clipping/clicking, etc.

Specs:
Intel Penitum P6200 Dual Core @2.13 GHz each
Intel HD Graphics 128 mb dedicated memory (runs games like Mass Effect 1, Torchlight 2, TF2 fine, although TF2 stutters a bit too.)
4 GB RAM

I tried disabling multicore rendering, but nothing happened. I also tried disabling Vsync.
Last edited by The Almighty TaDaryl; May 17, 2013 @ 4:16pm
< >
Showing 1-11 of 11 comments
Lunatix May 17, 2013 @ 5:04pm 
Awful graphic card and very medium processor, here is your problem.
I realize this, but I HAVE been able to run Source games well in the past. It is just in these last few months that they have started stuttering horribly.
Grampa Slade May 19, 2013 @ 7:27pm 
that just means they going to take a serous crap soon
I'm sorry, but that does not make much sense. What "crap" are we talking about?
ChiLLe May 20, 2013 @ 8:13pm 
He's saying your video card might be dying soon.
Last edited by ChiLLe; May 20, 2013 @ 8:13pm
Old Fart May 21, 2013 @ 1:15am 
agree....graphics card. and maybe your ip
I guess you guys do not understand very well. I can play all of my games fine, EXCEPT Source games. All of my Source games(Gmod, TF2, L4D2) have all played fine until recently. There is a stuttering problem.
Not trying to be rude, just trying to be more clear.
Horde Aug 12, 2013 @ 11:45am 
Originally posted by The Almighty TaDaryl:
Left 4 Dead 2 has been stuttering horrendously lately. I have tried lowering the settings, resolution, and whatnot, but is still stuttering and making it unplayable. I enabled the in-game FPS count and I got a range of 14-120. When no enemies, it ranges from 27-60 in a few seconds, and causes major hiccups, stutters, audio clipping/clicking, etc.

Specs:
Intel Penitum P6200 Dual Core @2.13 GHz each
Intel HD Graphics 128 mb dedicated memory (runs games like Mass Effect 1, Torchlight 2, TF2 fine, although TF2 stutters a bit too.)
4 GB RAM

I tried disabling multicore rendering, but nothing happened. I also tried disabling Vsync.

I've noticed this same exact situation on my PC too. I believe it started when this whole Steam Workshop started. While on the Menu in L4D2, anything I have subscribed to will auto-check for updates. Each time this happens (which I believe any time the hl2.exe is in use), all animations freeze for up to 2 seconds, and the audio will stutter momentarily. While in-game, this increases the possibility of death greatly.

I have been running both L4D2 and TF2 on highest settings for years now with this never happening. I use a GTX 480 Fermi, and AMD 1090T CPU, which is far more powerful than L4D2 or TF2 requires.

So, I blame Steam Workshop.

Exactly! I used to be able to have everything on medium/high, with I believe 1280x720 resolution, with minor lag drops to 28 frames when a hoard started. Now it isn't playable on any settings, but no matter what settings, it always stutters the same. Glad I'm not the only one
H20Wil Aug 12, 2013 @ 8:25pm 
Well, steam workshop shouldn't really affect you at all....
I just played the game again last night, and it's running great again. Not sure what happened back when I posted this, but I suppose it is resolved for now.

It may not have been Steam Workshop after all. I had one add on map for survival added on, and after I unchecked it, everything went fine. Maybe having Steam Workshop and that addon from before the Workshop update just didn't mix well.
< >
Showing 1-11 of 11 comments
Per page: 15 30 50

Date Posted: May 17, 2013 @ 4:15pm
Posts: 11