Buzz May 3, 2013 @ 9:20am
Pretty sick of this
Ok so I've had this problem for longer than I care to remember now and still no fix.

Whenever I try to play L4D2 it freezes at the Source screen. If I try to skip, it freezes.
I have tried uninstalling and re-installing, updating drivers, even changed my graphics card at one point and still nothing. I had it working about a year ago, but then it stopped again.

If I try to verify the game cache it gets to 5% then just does nothing, I've left it over night before and it was still on 5% in the morning.

Please tell me someone has a fix, and please do not post if you're just going to say "yeah I have the same problem" because that doesn't help anyone.

Rant over.

Thanks in advance to anyone who can help.
Showing 1-10 of 10 comments
< >
delirus May 3, 2013 @ 10:11am 
Did you delete your .blobs?
Buzz May 3, 2013 @ 10:40am 
I deleted the entire L4D2 folder in the steamapps folder after uninstalling
Casimer the Adequately Skilled May 3, 2013 @ 11:43am 
TF2 freezes for me when I open it, but it unfreezes after it finishes loading enough textures and sounds for the main menu. Your L4D2 could be doing something similar. How long have you waited with it open?
Buzz May 3, 2013 @ 12:03pm 
5 minutes is probably the longest, when I go to task manager it just says "not responding"
In the short time that it did work, there was no delay in loading, it just worked and then just didn't again.
Casimer the Adequately Skilled May 3, 2013 @ 12:05pm 
This may be a weird question, but have you rebooted recently? Sometimes rebooting can fix things that logic can't.
Last edited by Casimer the Adequately Skilled; May 3, 2013 @ 12:06pm
Buzz May 3, 2013 @ 12:57pm 
I switch my PC off most nights, and whenever I go on steam I try to load L4D2, so I'm pretty sure that I've covered that
ᗷᗴᗩᖇ May 3, 2013 @ 1:04pm 
Originally posted by kooky:
Did you delete your .blobs?


Originally posted by Dragonforce Kin:
I deleted the entire L4D2 folder in the steamapps folder after uninstalling

Try actually deleting the .blob files in the main steam directory. First exit steam. Delete clienresgistry.blob and appupdatestats.blob then restart steam. Next thing to try would be to once again exit steam, delete everything except steamapps/userdata folders and steam.exe. Then relaunch steam from that executable.
Buzz May 3, 2013 @ 2:15pm 
Didn't work :/
ᗷᗴᗩᖇ May 3, 2013 @ 2:28pm 
Have you tried the -novid/-novideo launch options?
Buzz May 3, 2013 @ 2:32pm 
Holy ♥♥♥♥ it worked!
Just got to hope it doesn't freeze during gameplay now haha!

Thanks a bunch!
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: May 3, 2013 @ 9:20am
Posts: 10