phittte Mar 19, 2013 @ 9:54am
Custom campaigns not working
I have a weird problem. When I download a custom campaign (any custom campaign, tried three different ones, all with top rating) it doesn't appear in the addons\workshop folder and when I start the game I shortly see the download bar with the name of the custom campaign in the main menu (even though it already finished downloading it before I started the game...), then the game CTDs without error. I can download other mods without problems (skybox mod, improved blood textures, even my own custom mutation worked) and they all show up in the addons folder.

Where does the Workshop download the campaign to? It downloads 200-300mb, but nothing ever appears in the addons folder. I searched for *.vpk in the left 4 dead 2 main folder, but there is nothing (except for the default game vpks and the non-campaign mods I have installed).

I can only assume that this is the problem - the game tries to activate the campaign, but it's not in the addons folder and for some weird reason the game is unable to download a custom campaign to the folder where it belongs.

Any ideas?

EDIT: After searching my whole hd I found it, it's in steam\userdata\bla...bla\myl4d2addons. Is it supposed to be there? Why is it not in the addons folder? Will try to move it manually now.

EDIT2: Copying the vpk into the addon folder worked (I can play it and no crashes), but now I have to check for updates regularly if I want to play the campaign online. Quite annoying. Still hoping someone has an idea why the Workshop downloads campaigns into the userdata folder instead of the l4d2 addons folder. I could try to put the mod into the addons\workshop folder and rename it so it has the number ID the Workshop download has. But I guess if there is an update it would still download it into the wrong folder. Weird.
Last edited by phittte; Mar 19, 2013 @ 12:47pm
Date Posted: Mar 19, 2013 @ 9:54am
Posts: 0