Left 4 Dead 2

Left 4 Dead 2

통계 보기:
Left 4 Dead 2 > 일반 토론 > 제목 정보
rustynutts()!()speedshop 2013년 10월 12일 오전 9시 37분
crashes after last new update 10/11/13 failed to lock vertex buffer in CMeshDX8::LockVertexbuffer
{failed to lock vertex buffer in CMeshDX8::LockVertexbuffer} i'm getting this error after map rotates to new map this is an old error from 2004
I have reinstalled l4d2/ gfx update newest driver/os update/still crashing same error
nice job valve/steam way to support clients i look forword to buying my steam game HELL NO I WILL NOT BUY ANY MORE GAME FOR STEAM PLATFORM/
rustynutts()!()speedshop님이 마지막으로 수정; 2013년 10월 16일 오전 9시 04분
< >
1-1552개 댓글 표시
4-4-4...4-THREE 2013년 10월 12일 오전 10시 09분 
i'm getting the exact same message whenever i try to join a confogl server. i can play in pubs though. i'm reinstalling, i'll let you know how it goes. as far as i know not everyone even got the update, but there are others who did and are having the same exact problem.
4-4-4...4-THREE님이 마지막으로 수정; 2013년 10월 12일 오전 10시 15분
Birdy 2013년 10월 12일 오전 10시 19분 
yes I have the same problem!
Its driving me mad
Also when its not crashing, l4d2 takes way longer then usual to close:(
Birdy님이 마지막으로 수정; 2013년 10월 12일 오전 10시 20분
Cronos__ 2013년 10월 12일 오전 10시 21분 
4-4-4...4-THREE 2013년 10월 12일 오전 11시 06분 
yeah i stop responding when i try to exit. if reinstall doesnt work i will rollback video drivers.
Birdy 2013년 10월 12일 오전 11시 11분 
reinstall did not fix anything here (yesterday)..
ok trying a reinstall again
Birdy님이 마지막으로 수정; 2013년 10월 12일 오전 11시 17분
4-4-4...4-THREE 2013년 10월 12일 오전 11시 14분 
reinstall fixed it for me, but for some reason it didnt go through a complete uninstallation. the game went back to the format/version it was in before the summer. when i click "delete local content" the game didnt go gray like it normally does and the "play" button was still there...it didnt say "download". I thought it was odd, but when i clicked play it brought up the message box saying it needed to convert to a newer, more efficient format. I let it go through that process and now i can join my confogl servers. i have also set the game not to update automatically in the properties tab.
4-4-4...4-THREE님이 마지막으로 수정; 2013년 10월 12일 오전 11시 14분
4-4-4...4-THREE 2013년 10월 12일 오전 11시 31분 
nevermind, as soon as i joined a pub game and then tried to go back to confogl i was getting the same error again and crashing :/
4-4-4...4-THREE 2013년 10월 12일 오전 11시 50분 
ok another update, at least for those of you joining non-valve servers, apparently you just keep joining/crashing until you finally load without crashing. Obviously a huge pain in the♥♥♥♥♥ but i found out a lot of my friends are crashing due to this error. They keep joining until it works.
Vetklep 2013년 10월 12일 오후 1시 22분 
I also experienced this error. Very annoying
JohnnSy 2013년 10월 12일 오후 1시 28분 
rekt #ReturnOfTheJedi님이 먼저 게시:
yeah i stop responding when i try to exit. if reinstall doesnt work i will rollback video drivers.

i have the same problem not only in l4d2 but also in cs go
JohnnSy님이 마지막으로 수정; 2013년 10월 12일 오후 1시 29분
4-4-4...4-THREE 2013년 10월 12일 오후 3시 28분 
hmm, if you are experiencing it in more than one game i would now guess that it is the steam client update and not just the l4d2 update. I've done some google searching, but i've only found one "fix" and it didnt work. It was something about running steam in compatibility mode (which you do not want to do) and i dont run it that way, so the fix didnt apply to me.
Project 90 - Type R 2013년 10월 12일 오후 4시 08분 
yup me n 3 mates having same prob, even joining our own vanilla server some times crashes some dont, gots let steam close game down then re join seems to be ok deffo only been last update.
validated files all was there and still done it poopers on some 1 there for that
distortnl 2013년 10월 13일 오전 3시 15분 
yep same problem here failed to lock vertex buffer in CMeshDX8::LockVertexBuffer
i can join 1 server, after disconneting and trying another one the game crashes
friday night it all was ok.
and i didn't change or install anything friday/saturday
first time that i have this problem, ive seen friends with this error earlier this year and some fixed it with video driver roll back.
i removed all addons tried some launch options (-dxlevel 80 and -dxlevel 90)
but that didn't work
l4d1 is ok i haven't tried other games

my current driver GeForce 327.23
distortnl님이 마지막으로 수정; 2013년 10월 13일 오전 3시 29분
EVILMISHMASH 2013년 10월 13일 오전 5시 51분 
Engine Error: Failed to lock vertex buffer in CMeshDX8::LockVertexBuffer

This started after the last update. NO changes on my system were made other than Steam/L4D2 update(s).

I get this error MORE OFTEN when joining CUSTOM campaigns-- not so much when joining official, but I cannot say for certain if its just custom campaigns.

I did search Steam Support and I did find this URL that explains it could be Paged Pool memory issue. HOWEVER please note this important note:

"This issue primarily affects systems running Windows XP 32-bit (most Windows XP Installations), Windows 2000 32-bit (most Windows 2000 installations), or on other systems with low RAM and a small or disabled page file. Most instances of paged pool exhaustion will result in a message which says "Internal driver error at Present. You're likely out of OS Paged Pool Memory" and a link to this article.
If your system is running Windows XP Professional x64 Edition (64-bit) or Windows Vista/7 (32 and 64-bit), and you have not modified your page file size, then this article should not apply to you. Please see Troubleshooting Game Crashes instead."


I am running WIndows 7 so I think this is not going to solve my issue.

IF the above does not help I will also start a support ticket and post the results, but you all know it can take several days to hear back from them.

I just came across something within the Steam Support section. I found it important enough to post here. Full article here https://support.steampowered.com/kb_article.php?ref=1040-JWMT-2947

Quote from Steam:--
-dxlevel <level> - Forces a specific DirectX version when launching the game. This is useful if your graphics hardware is older, and gets significantly better performance in an earlier version of DirectX. Below are the most common modes used:

-dxlevel 80
-dxlevel 81
-dxlevel 90
-dxlevel 95
-dxlevel 98

Our games no longer support DirectX 7 as a launch option. Using this can cause crashes. If you are using -dxlevel 70 make sure to remove it from your launch options. (end quote)

I gather setting launch opitions for Direct X7 is obsolete now.

EVILMISHMASH님이 마지막으로 수정; 2013년 10월 13일 오후 7시 45분
distortnl 2013년 10월 13일 오전 7시 18분 
this i still my first l4d2 installation, and has been working for years.
no overclocks active, cpu and mem are standard atm.

of course i did the standard verify cache thing.
i also checked pagefile settings (just standard automanage setting), even checked registry for steam.exe settings, couldnt find something strange.
disabled some stuff like fraps also checked sound devices and some other hardware, ran the dx diagnostics tool
also did a so called "torture test"
and changed the advanced l4d2 video settings to standard
all had no effect still the vertex crash.

after that i ran a chkdsk with the standard windows tool on the systemdrive. it fixed some minor things
i just tried again and now it's ok again, no crash to desktop anymore.
i am not convinced the windows error checking tool is the solution though
< >
1-1552개 댓글 표시
페이지당 표시 개수: 15 30 50

Left 4 Dead 2 > 일반 토론 > 제목 정보
게시된 날짜: 2013년 10월 12일 오전 9시 37분
게시글: 52