Creadoris Dec 7, 2013 @ 3:40pm
Seriously? We are still forced to used the low violence version?

I am sure number threads have been posted on here already but maybe it is time valve actually listened. Australia has had 18+ game rating for well over a year now yet this watered down travesty to the money we spend seems to have remained unchanged by that fact.

VALVE you do some great work but stop being so F$#%^@G lazy and resubmit this game for an updated rating. If you have the time/money to increase overall compatibility for those whinny Linux users or bring out yet another iteration of Team fortress, then you have the resourses to do this. So just do it already you neglectful tools.
Last edited by Creadoris; Dec 7, 2013 @ 6:48pm
Showing 1-6 of 6 comments
< >
AGENT Dec 7, 2013 @ 6:41pm 
Retro.
Dragon_Queen Dec 7, 2013 @ 7:20pm 
I wish.
Visi Dec 7, 2013 @ 8:57pm 
Creadoris Dec 7, 2013 @ 11:16pm 
Originally posted by Visi:
http://www.left4gore.com/

I am aware of its exsistance. But we shouldn't have to resort to using this.
Visi Dec 8, 2013 @ 12:02am 
Originally posted by Creadoirs:
Originally posted by Visi:
http://www.left4gore.com/

I am aware of its exsistance. But we shouldn't have to resort to using this.
I was just trying to be helpful.
SAQ_MADIQ Dec 8, 2013 @ 1:20am 
we shouldn´t have to use those patches..
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Dec 7, 2013 @ 3:40pm
Posts: 6