Left 4 Dead 2

Left 4 Dead 2

View Stats:
lavalamp360 Dec 29, 2013 @ 11:43am
Voice chat not working?
For some reason, the voice chat in L4D2 will not work. My mic settings in Steam are correct and test works. I start up L4D2 and the mic test in the options menu works. Then I create a lobby, invite my friend to the game, and neither of us can hear each other. Then when I go back into the options menu to test it again, it doesn't work. I have no idea why this is happening and can't come up with any ideas on how to fix it. We have to resort to using skype for communication right now which is really inefficient as it consumes additional system resources and bandwidth. Anyone else experiencing this problem and/or know how to fix it?
< >
Showing 1-15 of 16 comments
Mommy Dec 29, 2013 @ 2:45pm 
Hmmm are you in Linux?
Sigi Dec 29, 2013 @ 2:52pm 
This happen to me a few months ago annnnnnnnnd after that I start to use RC.
Grampa Slade Dec 29, 2013 @ 3:11pm 
chat in 2 has to my knowledge never worked in the lobby
klingeling Dec 29, 2013 @ 3:14pm 
In the lobby, there is a button to enable voice chat below the chat box. Did you use it?
Lesbian Pachimari Dec 29, 2013 @ 3:17pm 
Voice doesnt work in lobby. You cant use voice in lobby. Its been broken for 3 almost 4 years now and Volvo doesnt care to fix it. So your settings are fine. You just cant use voice in lobby.

Unless youre also talking about voice in game, then i dont know.
Last edited by Lesbian Pachimari; Dec 30, 2013 @ 4:27pm
lavalamp360 Dec 29, 2013 @ 5:34pm 
I'm on Windows and have done all of the above. Does voice chat ingame actually work fine though?
Smokson Dec 29, 2013 @ 5:37pm 
Go to options in the game and change option "Push to talk" to "Voice Recongnition" or something like that xD
Piroca Dec 29, 2013 @ 6:08pm 
try reinstaling the game
BaToDe Dec 29, 2013 @ 6:43pm 
windows
Peebly Jan 20, 2014 @ 1:41pm 
Mine too does not seem to work regardless of what I try
Vex Jan 21, 2014 @ 5:43am 
I had the same issue and than I selected push to talk option and selected ''C'' as activation key and had no problems since, the default ''ALT'' didn't work for me.
I'm talking about ingame chat.
Also if I reconnect my mic while ingame I have to restart game to make it work.
Lobby chat doesn't work for me either.
Maybe if someone reported this issue to Valve, they would fix it. I don't think the devs check the forums all that often.
jumpymonkey9 Dec 28, 2014 @ 9:56pm 
I know this is an older thread, but it came first in the google search. I found a way to fix the issue, at least temporarily, since I only tried it in one game so far. It's similar to what [PF]Vex said. I changed my voice option to push to talk, and then I had to bind a key to it since it wasn't set up. I went back to the game (was doing this all after I had set up a game already with a buddy) and he could hear me when I pushed that button. So, I went back and changed it from push to talk back to open mic. Then he was able to hear me all the time. My buddy went through those same steps and I was able to hear him. Hope this helps.
Vex Dec 29, 2014 @ 2:45am 
Glad it worked out for you aswell :)
A Crafty Sloth Aug 18, 2016 @ 8:25pm 
-Right click on volume button in the bottom right hand corner of your desktop
-select recording devices
-select your headphones/recording device
-there will be a button that says "set as default." Click that

that should work, it worked for me
< >
Showing 1-15 of 16 comments
Per page: 15 30 50

Date Posted: Dec 29, 2013 @ 11:43am
Posts: 16